PAT 1086 Tree Traversals Again (25)

16 篇文章 0 订阅
2 篇文章 0 订阅

1086 Tree Traversals Again (25)(25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路:

第一个push的一定是根节点,如果push a然后push b,那么b一定是a的左孩子,如果pop然后push a,那么a一定是上一次push节点的右孩子,根据这个规则可以还原出树,最后按照后序遍历输出。

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

struct node
{
	int lchild, rchild;
	node()
	{
		lchild = rchild = -1;
	}
};

vector<node> tree;
stack<int> s;
bool first = true;

void postorder(int root)
{
	if (root == -1)
		return;
	postorder(tree[root].lchild);
	postorder(tree[root].rchild);
	if (first)
	{
		first = false;
		cout << root;
	}
	else
		cout << " " << root;
}

int main()
{
	int n;
	cin >> n;
	tree.resize(n + 1);
	int root = -1, father, child;
	for (int i = 0; i < 2 * n; i++)
	{
		string operation;
		int index;
		cin >> operation;
		if (operation == "Push")
		{
			cin >> index;
			if (root == -1)
				root = index;
			else
			{
				if (!child)
					tree[father].lchild = index;
				else
					tree[father].rchild = index;
			}
			father = index;
			child = 0;
			s.push(index);
		}
		else
		{
			child = 1;
			father = s.top();
			s.pop();
		}
	}
	postorder(root);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值