UVA 10189 Minesweeper

UVA 10189 Minesweeper

Have you ever played Minesweeper? It’s a cute little game which comes within a certain Operating System which name we can’t really remember. Well, the goal of the game is to find where are all the mines within a M ×N field. To help you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4×4 field with 2 mines (which are represented by an ‘*’ character):

*...

....

.*..

....

If we would represent the same field placing the hint numbers described above, we would end up with:

*100

2210

1*10

1110

As you may have already noticed, each square may have at most 8 adjacent squares.

Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m ≤ 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters and represent the field.

Each safe square is represented by an ‘.’ character (without the quotes) and each mine square is represented by an ‘*’ character (also without the quotes). The first field line where n = m = 0 represents the end of input and should not be processed.

Output

For each field, you must print the following message in a line alone:
Field #x:
Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the ‘.’ characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.

Sample Input

4 4

*...

....

.*..

....

3 5

**...

.....

.*...

0 0

Sample Output

Field #1:

*100

2210

1*10

1110

Field #2:

**100

33200

1*100

 

思路:可以一开始的时候把存field的数组都初始化为'0',如果输入‘*’,则用'*'取代相应位置上的字符,然后以它为中心的8-邻域中不是‘*’的位置都可以+1,因为一个‘*’只会对它的8-邻域产生影响,如果输入‘.',则无需操作。

代码:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include<queue>
#include<map>
#include<set>
using namespace std;

char field[105][105];

int main()
{
	int m, n, t = 0;
	scanf("%d%d", &m, &n);
	while (m && n)
	{
		for (int i = 0; i < m; i++)
		{
			for (int j = 0; j < n; j++)
				field[i][j] = '0';
		}
		for (int i = 0; i < m; i++)
		{
			getchar();//过滤回车
			for (int j = 0; j < n; j++)
			{			
				char ch = getchar();
				if (ch == '*')
				{
					field[i][j] = '*';
					if (i - 1 >= 0 && j - 1 >= 0 && field[i - 1][j - 1] != '*')
						field[i - 1][j - 1]++;
					if (i - 1 >= 0 && field[i - 1][j] != '*')
						field[i - 1][j]++;
					if (i - 1 >= 0 && j + 1 < n && field[i - 1][j + 1] != '*')
						field[i - 1][j + 1]++;
					if (j - 1 >= 0 && field[i][j - 1] != '*')
						field[i][j - 1]++;
					if (j + 1 < n && field[i][j + 1] != '*')
						field[i][j + 1]++;
					if (i + 1 < m && j - 1 >= 0 && field[i + 1][j - 1] != '*')
						field[i + 1][j - 1]++;
					if (i + 1 < m && field[i + 1][j] != '*')
						field[i + 1][j]++;
					if (i + 1 < m && j + 1 < n && field[i + 1][j + 1] != '*')
						field[i + 1][j + 1]++;
				}
			}			
		}
		if(t)
			printf("\n");
		printf("Field #%d:\n", ++t);
		for (int i = 0; i < m; i++)
		{
			for (int j = 0; j < n; j++)
				printf("%c", field[i][j]);
			printf("\n");
		}
		scanf("%d%d", &m, &n);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值