sdut 2605 Mountain Subsequences(树状数组)

Mountain Subsequences

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Coco is a beautiful ACMer girl living in a very beautiful mountain. There are many trees and flowers on the mountain, and there are many animals and birds also. Coco like the mountain so much that she now name some letter sequences as Mountain Subsequences.

 

A Mountain Subsequence is defined as following:

1. If the length of the subsequence is n, there should be a max value letter, and the subsequence should like this, a1 < ...< ai < ai+1 < Amax > aj > aj+1 > ... > an

2. It should have at least 3 elements, and in the left of the max value letter there should have at least one element, the same as in the right.

3. The value of the letter is the ASCII value.

 

Given a letter sequence, Coco wants to know how many Mountain Subsequences exist.

输入

Input contains multiple test cases.

For each case there is a number n (1<= n <= 100000) which means the length of the letter sequence in the first line, and the next line contains the letter sequence.

Please note that the letter sequence only contain lowercase letters. 

输出

For each case please output the number of the mountain subsequences module 2012.

示例输入

4abca

示例输出

4

提示

The 4 mountain subsequences are:

aba, aca, bca, abca


题目链接:http://acm.sdut.edu.cn/sdutoj/problem.php?action=showproblem&problemid=2607

思路:看作是是任意字符,则想成了是树状数组。

刚刚好,复习一下树状数组,O(∩_∩)O~~

这个是由树状数组优化:

原先的状态转移方程为:

for(int i=0;i<n;i++)
{
    for(int j=0;j<i;j++)
    if(num[j]<num[j])
       dp[i]+=dp[j];
    l[i]=dp[i];
    dp[i]++;
}
明显的是这个时间复杂度是n^2,绝逼是要超时,gg

此时就需要用树状数组优化内层循环;

这里就不多说了,如果不知道,那么自己去了解吧b( ̄▽ ̄)d

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn=111111;
const int mod=2012;
typedef long long ll;
int l[maxn],r[maxn],bit[maxn],num[maxn];
char s[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int k)
{
    while(x<1000)
    {
        bit[x]+=k;
        bit[x]%=mod;
        x+=lowbit(x);
    }
}
int sum(int x)
{
    int ans=0;
    while(x)
    {
        ans+=bit[x];
        ans%=mod;
        x-=lowbit(x);
    }
    return ans%mod;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%s",s);
        memset(bit,0,sizeof(bit));
        for(int i=0;i<n;i++)
        {
            num[i]=s[i]-' '+10;
            l[i]=sum(num[i]);
            add(num[i]+1,l[i]+1);
        }
        memset(bit,0,sizeof(bit));
        for(int i=n-1;i>=0;i--)
        {
             r[i]=sum(num[i]);
            add(num[i]+1,r[i]+1);
        }
        int ans=0;
        for(int i=0;i<n;i++)
        {
            printf("%d %d\n",l[i],r[i]);
            l[i]%=mod;
            r[i]%=mod;
            ans+=l[i]*r[i]%mod;
            ans%=mod;
        }
        cout<<(ans+mod)%mod<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值