FOJ 1914 Funny Positive Sequence

                                                                           Funny Positive Sequence

Accept: 422    Submit: 1860
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

There are n integers a 1,a 2,…,a n-1,a n in the sequence A, the sum of these n integers is larger than zero. There are n integers b 1,b 2,…,b n-1,b n in the sequence B, B is the generating sequence of A and bi = a 1+a 2,+…+a i (1≤i≤n). If the elements of B are all positive, A is called as a positive sequence.

We left shift the sequence A 0,1,2,…,n-1 times, and get n sequences, that is showed as follows:

A(0): a1,a2,…,an-1,an

A(1): a2,a3,…,an,a1

A(n-2): an-1,an,…,an-3,an-2

A(n-1): an,a1,…,an-2,an-1

Your task is to find out the number of positive sequences in the set { A(0), A(1), …, A(n-2), A(n-1) }.

Input

The first line of the input contains an integer T (T <= 20), indicating the number of cases. Each case begins with a line containing one integer n (1 <= n <= 500,000), the number of elements in the sequence. The next line contains n integers ai(-2,000,000,000≤ai≤2,000,000,000,1≤i≤n), the value of elements in the sequence.

Output

For each test case, print a line containing the test case number (beginning with 1) and the number of positive sequences.

Sample Input

2
3
1 1 -1
8
1 1 1 -1 1 1 1 -1

Sample Output

Case 1: 1
Case 2: 4


题目链接: http://acm.fzu.edu.cn/problem.php?pid=1914

题目大意:给你n个数,计算前缀和,若每个前缀和都大于零,则加一;
把第一个数调到最后,计算
直至把倒数第二个数调到最后,
输出最后答案

思路分析:
其实只需要知道非正数的影响就好了。
当然;
因为有位置的调换,则可以适当的增长数组长度,将1~n-1个数在赋值到数组的后头;
从后往前扫描,为非整数则标记为1,为正数则赋值为零
最后扫描一下1~n 有多少个没有被标记则是最终答案;
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=511111*2;
ll num[maxn],l[maxn],r[maxn];
int vis[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%I64d",&num[i]);
        for(int i=0;i<n-1;i++)
            num[n+i]=num[i];
        ll total=0;
        int m=n;
        n+=n-1;
        int i=n-1;
        memset(vis,0,sizeof(vis));
        while(i>=0)
        {
            total+=num[i];
            while(total<=0&&i>=0)
            {
                vis[i]=1;
                i--;
                total+=num[i];
            }
            total=0;
            i--;
        }
        int ans=0;
        for(int i=0;i<m;i++)
        if(!vis[i])
          ans++;
        printf("Case %d: %d\n",t,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值