Funny Positive Sequence

Description

  There are n integers a 1,a 2,…,a n-1,a n in the sequence A, the sum of these n integers is larger than zero. There are n integers b 1,b 2,…,b n-1,b n in the sequence B, B is the generating sequence of A and bi = a 1+a 2,+…+a i (1≤i≤n). If the elements of B are all positive, A is called as a positive sequence.

We left shift the sequence A 0,1,2,…,n-1 times, and get n sequences, that is showed as follows:

A(0): a1,a2,…,an-1,an

A(1): a2,a3,…,an,a1

A(n-2): an-1,an,…,an-3,an-2

A(n-1): an,a1,…,an-2,an-1

Your task is to find out the number of positive sequences in the set { A(0), A(1), …, A(n-2), A(n-1) }.

Input

  The first line of the input contains an integer T (T <= 20), indicating the number of cases. Each case begins with a line containing one integer n (1 <= n <= 500,000), the number of elements in the sequence. The next line contains n integers ai(-2,000,000,000≤ai≤2,000,000,000,1≤i≤n), the value of elements in the sequence.

Output

  For each test case, print a line containing the test case number (beginning with 1) and the number of positive sequences.

Sample Input

2
3
1 1 -1
8
1 1 1 -1 1 1 1 -1

Sample Output

Case 1: 1
Case 2: 4

思路(借鉴)

变量total表示所有符合条件的系列, 开始total=n;

从后往前扫描, 遇到负数就向前累加total--且flag[i]=1(表示已被访问过) , 直到和为正数为止.

这样遍历完整个数组,如果到遍历完后累加和sum<=0, 则将sum再从数组最后开始累加直到和为正, 此时, 如果flag[i]=0则total--;

代码

#include<stdio.h>
#include<string.h>
#define MAX 500005
__int64 num[MAX];
int flag[MAX];
int main()
{
    int T,kase=1;
    scanf("%d",&T);
    while(T--)
    {
        int n,i;
        memset(flag,0,sizeof(flag));
        scanf("%d",&n);
        for(i=0;i<=n-1;i++)
        {
            scanf("%I64d",&num[i]);
        }
        __int64 sum=num[n-1];
        int total=n;
        if(sum<=0)
        {
            total-=1; flag[n-1]=1;
        }
        for(i=n-2;i>=0;i--)
        {
            if(sum<=0)
            {
                sum+=num[i];
                if(sum<=0)
                {
                    total-=1;
                    flag[i]=1;
                }
            }
            else
            {
                if(num[i]<=0)
                {
                    sum=num[i];
                    total-=1;
                    flag[i]=1;
                }
            }
        }
        if(sum<=0)
        {
            for(i=n-1;i>=0;i--)
            {
                sum+=num[i];
                if(sum<=0&&!flag[i])
                    total-=1;
                if(sum>0) break;
            }
        }
        printf("Case %d: %d\n",kase,total);
        kase+=1;
    }
    return 0;
}

  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值