HDU 6063

RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki ∑i=1nkμ2(i)×⌊nki⌋

output the answer module 109+7 109+7.
1n,k1018 1≤n,k≤1018
μ(n)=1(n=1) μ(n)=1(n=1)

μ(n)=(1)k(n=p1p2pk) μ(n)=(−1)k(n=p1p2…pk)

μ(n)=0(otherwise) μ(n)=0(otherwise)

p1,p2,p3pk p1,p2,p3…pk are different prime numbers
Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k n,k.
Output
For each test case, output "Case #x: y", which means the test case number and the answer.
Sample Input
10 10
Sample Output

Case #1: 999999937


这个问题最终是求n^k,也就是快速幂问题。快速幂知识请查看  点击打开链接

#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
const LL mod=1e9+7;

LL fastpower(LL  n,LL k)    //快速幂的运用
{
    LL ans=1,vis=n;
    while(k!=0)
    {
        if(k&1==1)
            ans=((ans%mod)*(vis%mod))%mod;
        vis=((vis%mod)*(vis%mod))%mod;	//注意vis必须每次先取模再乘积,否则vis会超过long long 类型的范围。
        k>>=1;                          // k=k/2;
    }

    return ans;
}


int main()
{
    LL n,k,answer;
    int t=1;
    while(scanf("%I64d%I64d",&n,&k)!=EOF)
    {
        answer=fastpower(n,k);
         printf("Case #%d: %lld\n", t++, answer);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值