HDU 6063-RXD and math

链接:http://acm.hdu.edu.cn/showproblem.php?pid=6063
Problem Description
这里写图片描述

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k.

Output
For each test case, output “Case #x: y”, which means the test case number and the answer.

Sample Input
10 10

Sample Output
Case #1: 999999937

莫比乌斯反演 , 他们 说小学奥赛都学过 ,但我 没发处理那个阶乘,
所以 就10^10 mod 1e9+7 发现 刚好等于答案 ,然后 就开始了 暴力之路 。
但要注意2点 , 阶乘用 快速幂 别傻傻的for循环, 就是每次* 的前后 和开始都要取模
代码:

#include<bits/stdc++.h>
#define mod 1000000007
//#define mod 1e9+7
using namespace std;
long long pow(long long a,long long b)
{
   long long int ans = 1,base = a;
    while(b!=0)
    {
        if(b&1){
            base%=(long long)mod;
            ans%=(long long)mod;
            ans *= base;
            ans%=(long long)mod;
        }
        base%=(long long)mod;
        base *= base;
        base%=(long long)mod;
        b>>=1;
    }
    return ans;
}
int main()
{
    long long int n,k;
    int t=0;
    while(~scanf("%lld %lld",&n,&k)){
            t++;
        printf("Case #%d: ",t);
        printf("%lld\n",pow(n,k));
    }
    return 0;
}

顺便附上 整数快速幂 讲解:
http://blog.csdn.net/changjiale110/article/details/76467887

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值