Poj3061 尺取法

Subsequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33132 Accepted: 13783

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

Source

Southeastern Europe 2006

 

   尺取法,即为在线性数组上对某一区间段操作。每次根据情况移动区间起点或区间终点,从而避免在线性空间上的O(N^2)操作。这道题要求大于等于某一数值S,那么我们就按照这个标准在区间上移动,满足这个条件就判断当前长度是不是最小长度,不满足这个条件我们就继续移动区间。

#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;

int arr[100000+5];

int main(){
	int casen;
	cin>>casen;
	while(casen--){
		int S,N;
		cin>>N>>S;
		for(int i=0;i<N;i++){
			scanf("%d",&arr[i]);
		}
		int st=0,en=0;
		int now=0; 
		int ans=100000000;
		while(en<N){
			if(now>=S){
				ans=min(ans,en-st);
				now-=arr[st++];
			}else{
				now+=arr[en++];
			}
		}
		
		while(now>=S){
			ans=min(ans,en-st);
			now-=arr[st++];
		}
		cout<<(ans==100000000? 0:ans)<<endl;
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值