PAT 1049. Counting Ones (30)(数位dp(记忆化搜索))

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1’s in one line.

Sample Input:
12
Sample Output:
5
题意很好理解,求1到n这n个数其中1总共出现了多少次。
还是比较基础的数位dp,dp数组建议使用结构体,保存两个量,1出现了多少次和总共有多少个数。至于为什么呢,也是很好理解的,如果当前位不是1,那么总共出现的1的个数和当前位减一出现的1的个数相等,如果当前位是1,那么出现1的个数由两部分组成,当前位减一出现1的个数和从当前位开始总共有多少个数,因为如果当前位是1,那么前面只要存在一个数,那么1的总数就会加一。
详细见代码:

#include <iostream>
#include <string>
#include <cstring>
#include <iomanip>
#include <cmath>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
#include <map>
#include <stack>
#include <queue>
using namespace std;
#define ll long long
#define maxn 20
#define angel 0x3f3f3f3f
#define eps 1e-9
const int mod=1e9+7;
struct maths
{
    ll cnt;//出现1的个数
    ll sum;//总共多少个数
}dp[maxn];
int tmp[maxn];
maths dfs(int len,int flag)
{
    if(len==0)
    {
        maths element;
        element.sum=1;element.cnt=0;
        return element;
    }
    if(!flag&&dp[len].sum!=-1)
        return dp[len];
    int maxx=flag?tmp[len]:9;
    maths now;
    now.cnt=now.sum=0;
    for(int i=0;i<=maxx;i++)
    {
        maths next=dfs(len-1,i==maxx&&flag);
        if(i==1)
            now.cnt=now.cnt+next.cnt+next.sum;
        else
            now.cnt=now.cnt+next.cnt;
        now.sum+=next.sum;
    }
    if(!flag)
        dp[len]=now;
    return now;
}
ll solve(int n)
{
    int len=0;
    while(n>0)
    {
        tmp[++len]=n%10;
        n/=10;
    }
    return dfs(len,1).cnt;
}
int main()
{
    int n;
    scanf("%d",&n);
    memset(dp,-1,sizeof(dp));
    printf("%lld\n",solve(n));
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值