ACM(java)--简单输入输出题

简单输入输出题

寒假要好好学习,天天向上,然后就用java刷下题哈,,,唉,顺便巩固下java语法练练手,毕竟要靠java吃饭哈,这一周是简单的题,从下周开始就是专题训练

A - A+B for Input-Output Practice (I)

Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
1 5
10 20

Sample Output
6
30
思路:这道题真是的acm的编程入门题啊啊啊,当年用C刷的时候,都栽在上面了,用java刷的时候第一次还是没过,这道题的关键是让你看清可以多次输入

import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
         Scanner input = new Scanner(System.in);
         int a,b;
         while(input.hasNextInt()){
            a = input.nextInt();
            b = input.nextInt();
            System.out.println(a+b);
         }
    }
}
public boolean hasNextInt()
如果通过使用 nextInt() 方法,此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 int 值,则返回 true。扫描器不执行任何输入。 
返回:
当且仅当此扫描器的下一个标记是有效的 int 值时才返回 true 
抛出: 
IllegalStateException - 如果此扫描器已关闭

B - A+B for Input-Output Practice (II)
Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.

Output
For each pair of input intege

评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值