How Many Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 25485 Accepted Submission(s): 12724
Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
Sample Output
2 4
思路:裸的并查集,求连通块的数目。
#include<cstdio>
using namespace std;
int T,M,N;
int pre[1000];
int find(int x)//查找根结点
{
int r=x;
while(pre[r]!=r)//返回根结点r
r=pre[r];
int i=x;
int j;
while(i!=r)//路径压缩
{
j=pre[i];//先保存i的上级结点
pre[i]=r;//i的上级结点变为根结点
i=j;//把i设为i的上级结点,一直进行路径压缩
}
return r;
}
void join(int x,int y)
{
int fx=find(x);//找到x的根结点
int fy=find(y);//找到y的根结点
if(fx!=fy)
pre[fx]=fy;//把x和y连通
}
int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&N,&M);
for(int i=1;i<=N;i++)
pre[i]=i; //初始化并查集
int x,y;
for(int i=0;i<M;i++)
{
scanf("%d%d",&x,&y);
join(x,y);
}
//求有多少个连通块
int ans=0;
for(int i=1;i<=N;i++)
if(pre[i]==i)
ans++;
printf("%d\n",ans);
}
return 0;
}