HDU1542——Atlantis(扫描线,线段树,矩形面积并,离散化)

I - Atlantis
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity. 
 

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 

Output a blank line after each test case. 
 

Sample Input

      
      
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output

      
      
Test case #1 Total explored area: 180.00
 

裸的矩形面积并的题目。

打的大神的模板。比较难理解的地方写在注释里头了。


#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
#include <string>
#include <map>
#include <queue>
#include <set>
#include <stack>
using namespace std;
#define MAXN 100010
#define LEN 200010
#define INF 1e9+7
#define MODE 1000000
#define pi acos(-1)
#define g 9.8
typedef long long ll;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

double sum[MAXN<<2];
double X[MAXN<<2];
int cnt[MAXN<<2];//该区间上边比下边多几个

struct Seg{
	double h,l,r;
	int s;
}ans[MAXN];

int cmp(Seg a,Seg b)
{
    return a.h<b.h;
}


void PushUp(int rt,int l,int r){
	if(cnt[rt])
		sum[rt]=X[r+1]-X[l];
	else if(l==r)
		sum[rt]=0;
	else
		sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void update(int L,int R,int c,int l,int r,int rt){
	if(L<=l&&r<=R){
		cnt[rt]+=c;
		PushUp(rt,l,r);
		return;
	}
	int m=(l+r)>>1;
	if(L<=m)
		update(L,R,c,lson);
	if(m<R)
		update(L,R,c,rson);
	PushUp(rt,l,r);
}

//二分法找到X中等于该端点的值的下标,找不到就返回-1
int Bin(double key,int n,double X[]){
	int l=0,r=n-1;
	while(l<=r){
		int m=(r+l)>>1;
		if(X[m]==key)
			return m;
		if(X[m]<key)
			l=m+1;
		else
			r=m-1;
	}
	return -1;
}

int main(){
	int n,cas=1;
	while(scanf("%d",&n)!=EOF&&n){
		int m=0;
		while(n--){
			double a,b,c,d;
			scanf("%lf%lf%lf%lf",&a,&b,&c,&d);
			//分别记录左右端点
			X[m]=a;
			ans[m].h=b;
			ans[m].l=a;
			ans[m].r=c;
			ans[m].s=1;
			m++;
			X[m]=c;
			ans[m].h=d;
			ans[m].l=a;
			ans[m].r=c;
			ans[m].s=-1;
			m++;
		}
		sort(X,X+m);//把线段端点从小到大排序
		sort(ans,ans+m,cmp);//把线段从低到高排序
		int k=1;
		//取出不重复的点
		for(int i=1;i<m;i++){
			if(X[i]!=X[i-1])
				X[k++]=X[i];
		}
		memset(cnt,0,sizeof(cnt));
		memset(sum,0,sizeof(sum));
		double res=0;
		for(int i=0;i<m-1;i++){
			int l=Bin(ans[i].l,k,X);
			int r=Bin(ans[i].r,k,X)-1;
			if(l<=r)
				update(l,r,ans[i].s,0,k-1,1);
			res=res+sum[1]*(ans[i+1].h-ans[i].h);//sum表示当前区间覆盖的x轴的长度
		}
        printf("Test case #%d\n",cas++);
        printf("Total explored area: %.2f\n\n",res);
	}
}












  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值