POJ2955——Brackets(区间dp)

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6335 Accepted: 3388

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6
简单区间dp

看代码吧


#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <iostream>
using namespace std;
const int MAXN =310;
const int INF =1000000007 ;
const int MOD =1000000007;
const double EPS=1e-8;
const double pi = acos(-1);
int dp[MAXN][MAXN];
string s;
int a[MAXN];
int main()
{
    std::ios::sync_with_stdio(false);
    while(cin>>s){
        if(s[0]=='e')
            break;
        memset(dp,0,sizeof(dp));
        int n=s.length();
        for(int i=0;i<n;i++)
        {
            if(s[i]=='(')
                a[i]=1;
            if(s[i]==')')
                a[i]=-1;
            if(s[i]=='[')
                a[i]=2;
            if(s[i]==']')
                a[i]=-2;
        }
        int res=0;
        for(int k=1;k<=n-1;k++){
            for(int i=0;i+k<n;i++){
                int j=i+k;
                for(int m=i;m<=j-1;m++){
                    dp[i][j]=max(dp[i][j],dp[i][m]+dp[m+1][j]);
                }
                if(a[i]+a[j]==0&&a[i]>0){
                    dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
                }
                res=max(dp[i][j],res);
            }
        }
     printf("%d\n",res);
}
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值