HDU 5984 Pocky (数学)

Pocky

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 556    Accepted Submission(s): 302


Problem Description
Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.
 

Input
The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.
 

Output
For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.
 

Sample Input
  
  
6 1.0 1.0 2.0 1.0 4.0 1.0 8.0 1.0 16.0 1.0 7.00 3.00
 

Sample Output
  
  
0.000000 1.693147 2.386294 3.079442 3.772589 1.847298
 

Source
 

Recommend
jiangzijing2015
 


#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstring>

using namespace std;
const int INF=1e9+7;
long long int fact[101];

void init(){
    fact[0]=1;
    for(int i=1;i<=20;i++){
        fact[i]=fact[i-1]*i;
    }
}

int main(){
    double x,y;
    int cases;
    init();
    scanf("%d",&cases);
    while(cases--){
        double res=0;
        scanf("%lf%lf",&x,&y);
        if(x<=y){
            printf("%.6lf\n",0);
            continue;
        }
        double tmp1=log(x)-log(y);
        double tmp2=y*1.0/x;
        for(int i=1;i<=20;i++){
            double tmp=1;
            tmp*=tmp2;
            tmp*=pow(tmp1,i-1);
            tmp*=i;
            tmp/=fact[i-1];
            res+=tmp;
        }
        printf("%.6lf\n",res);
    }
    return 0;
}
/*
1
1 4 1 4
2 1 2 1
3 2 3 2
4 3 4 3
5 5 5 5
6 6 6 6

*/





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值