poj 1159 Palindrome

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 44186 Accepted: 15050

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5

Ab3bd

Sample Output

2

题意:求至少多少个字符,使得该字符串是一个回文串

思路:回文串就是顺着读,逆着读都是一样的,先把原字符串 A 翻转 存为 B,求A,B的最长公共子序列 长度L,那么不相同的字符就是 n-L ,因为题目要求只能加字符进去,那么,有多少个不相同的就在其相对的位置加对应的字符就行了,就是说n-L就是所求解了,但是注意到的是N最大可以取5000,开一个dp[5000][5000]的数组会MLE的,所以要有个空间优化,详细见代码。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#define maxn 5005
#define loop(a,b,c) for(int a=b;a<=c;a++)
#define nloop(a,b,c) for(int a=b;a>=c;a--)
#define clr(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
char word[maxn],test[maxn];
int dp[2][maxn];
int main()
{
    int n;
    while(cin>>n)
    {
        int now=1;
        clr(dp,0);
        loop(i,1,n)
        cin>>word[i];
        loop(i,1,n)
        test[i]=word[n-i+1];
        loop(i,1,n)
        {
            loop(j,1,n)
            if(word[i]==test[j]) dp[now][j]=dp[!now][j-1]+1;
            else dp[now][j]=max(dp[!now][j],dp[now][j-1]);
            now=!now;
        }
        cout<<n-dp[!now][n]<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值