数论  约数之和

For an integer n, define f(n) to be the sum of its proper divisors (the divisors excluding the number itself), f is called the restricted divisor function.

Given an integer m. Find how many integers n between 1 and 1000000 (inclusively) has f(n)<=m.


Input



The input contains several cases, each has a single integer m on a seperate line. All input data fit in a signed 32-bit integer.


Output



The answer for each case should be printed on a seperate line.


Sample Input



1
3392927
3392928


Sample Output



78499
999999
1000000

题目大意:F[N]表示 的约数的和(不包括N)。。给定M,求1-1000000中F[N]>=M的个数。。

#include <iostream>

#include <cmath>

#include <algorithm>

#include <vector>

#include <stdlib.h>

#include <queue>

#include <cstdio>

#include <set>

#include <map>

#include <string.h>

#include <string>

using namespace std;

#define MAX 1000000


int ans[MAX+5];


void init()

{

ans[1] = 0;

memset(ans,0,sizeof(ans));

for(int i = 1 ; i<= MAX/2; i++)

for(int j = 2 ; i*j <= MAX ;j++)

{

ans[i*j] += i;                       

}

sort(ans,ans+MAX+1);

}


int main()

{

init();

int n;

while(scanf("%d",&n) != EOF)

{

if(n >= 3392928) 

{

printf("1000000\n");

continue;

}


for(int i = 1 ; i<= MAX; i++)

{

if(ans[i] > n)

{

printf("%d\n",i-1);

break;

}

}

}

   

    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值