PAT_A 1105. Spiral Matrix (25)

1105. Spiral Matrix (25)

  • 题目信息
    This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
    Sample Input:

    12
    37 76 20 98 76 42 53 95 60 81 58 93

    Sample Output:

    98 95 93
    42 37 81
    53 20 76
    58 60 76

  • 简述
    其实就是讲一堆数排序后,顺时针填充二位数组,挺绕的。

  • 我那超长的代码(下次总结,看以下别人是怎么做的)
    • 代码太长了
    • vector按序加入数据,这个忘了,以后回来再改。
#include<iostream>
#include<vector>
#include<algorithm>
#include<cmath>
int m[10000][10000];
using namespace std;
int r=0;
int c=0;
//顺时针填充数组
void ass(vector<int>&d)
{
    int l=0;
    int ii=1;
    int jj=1;
    int size=d.size()-1;
    int pos=1;
    while(d[0]!=size)
    {
        if(l==0)
        {
            l=1;
            for(int i=1;i<=c;i++)
            {
                if(m[ii][i]==0)
                {
                    jj=i;
                    m[ii][jj]=d[pos];
                    pos++;
                    d[0]++;
                }
            }
        }
        else if(l==1)
        {
            l=2;
            for(int i=1;i<=r;i++)
            {
                if(m[i][jj]==0)
                {
                    ii=i;
                    m[ii][jj]=d[pos];
                    pos++;
                    d[0]++;
                }
            }
        }
        else if(l==2)
        {
            l=3;
            for(int i=c;i>0;i--)
            {
                if(m[ii][i]==0)
                {
                    jj=i;
                    m[ii][jj]=d[pos];
                    pos++;
                    d[0]++;
                }
            }

        }else
        {
            l=0;
            for(int i=r;i>0;i--)
            {
                if(m[i][jj]==0)
                {
                    ii=i;
                    m[ii][jj]=d[pos];
                    pos++;
                    d[0]++;
                }
            }
        }

    }
}
bool cam(int a,int b)
{
    return a>b;
}
int main()
{
    int n;
    vector<int> d;
    vector<int> v;
    d.push_back(0);
    v.push_back(0);
    //需要添加数据时,直接排序
    cin>>n;
    for(int i=0;i<n;i++)
    {
        int tmp;
        cin>>tmp;
        d.push_back(tmp);
        v.push_back(0);
    }
    int half=sqrt(n);
    for(int i=half;i>0;i--)
    {
        if(n%i==0)
        {
            half=i;
            break;
        }
    }
    c=half;
    r=n/c;

    sort(d.begin()+1,d.begin()+d.size(),cam);

    ass(d);
    for(int i=1;i<=r;i++)
    {
        for(int j=1;j<=c;j++)
        {
          cout<<m[i][j];
          if(j<c)
            cout<<" ";
        }
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值