暑假集训日记--8.11--二分+单调队列

今天一天基本都在做题……

然后又学了一下单调队列。

下面附单调队列的最基础的题:

Problem Description
An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  knumbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

 

Input
The input consists of two lines. The first line contains two integers <I>n</I> and <I>k</I> which are the lengths of the array and the sliding window. There are <I>n</I> integers in the second line. <br>
 


Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. <br>
 

Sample Input
  
  
8 3 1 3 -1 -3 5 3 6 7
 

Sample Output
  
  
-1 -3 -3 -3 3 3 3 3 5 5 6 7
 

这算是单调队列的另一种描述了。

想取得的最值一直出现在队首。用head控制队首。只需要保存前k-1个的最值。


所以当队首的元素的下标小于i-k+1的时候,就说明队首的元素对于求f(i)已经没有意义了。所以当index[队首元素]<i-k+1时,将队首元素删除。

单调队列与普通队列的区别也就在于需要保存元素位置。

然而现在队首元素位置的移动……还是有点晕。

附这个题的代码:

//1009:Sliding Window
/*单调队列问题*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <stdio.h>
#include <string>
#define MAX 1000000
using namespace std;
int num[MAX];
int q[MAX];
int I[MAX];
int n,k;
void getmin()
{
    int head = 1,tail = 0;
    for (int t = 1; t < k; t++)
    {
        while (head <= tail && q[tail] >= num[t])
            tail--;
        tail++;
        q[tail] = num[t];
        I[tail] = t;
    }
    for (int t = k; t <= n; t++)
    {
        while (head <= tail && q[tail] >= num[t])
            tail--;
        tail++;
        q[tail] = num[t];
        I[tail] = t;
        while (I[head] <= t - k)
            head++;
        cout << q[head] << " ";
    }
}
void getmax()
{
    int head = 1,tail = 0;
    for (int t = 1; t < k; t++)
    {
        while (head <= tail && q[tail] <= num[t])
            tail--;
        tail++;
        q[tail] = num[t];
        I[tail] = t;
    }
    for (int t = k; t <= n; t++)
    {
        while (head <= tail && q[tail] <= num[t])
            tail--;
        tail++;
        q[tail] = num[t];
        I[tail] = t;
        while (I[head] <= t - k)
            head++;
        cout << q[head] << " ";
    }
}
int main()
{
    scanf("%d%d", &n,&k);
    for (int i = 1; i <= n; i++)
        scanf("%d",&num[i]);
    getmin();
    printf("\n");
    getmax();
    printf("\n");
    return 0;
}

然后现在在做一个二分题……先去把这个题A掉……感觉很水的一道题

明天继续学习。。。单调队列。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值