8.22--练习赛F题--Muddy roads (模拟)

原题:

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools. 

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely. 

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.
Input
* Line 1: Two space-separated integers: N and L 

* Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap. 
Output
* Line 1: The miminum number of planks FJ needs to use.
Sample Input
3 3
1 6
13 17
8 12
Sample Output
5
Hint
INPUT DETAILS: 

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17. 

OUTPUT DETAILS: 

FJ can cover the mud pools with five planks of length 3 in the following way: 
                   111222..333444555....

                   .MMMMM..MMMM.MMMM....

                   012345678901234567890
题意:铺路问题。给出n段长度的起止位置,要求用长为l的木板铺路,最少用多少块木板可以铺完。

思路:

既然给出n个泥坑的起止位置,而且不重合,那么就按照开始的位置进行排序。

排序后从头开始铺木板。具体见代码。

源代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <stdio.h>
#include <cmath>
#define MAX 100000
using namespace std;
struct DIS
{
    int s,e;
}dis[MAX];
bool cmp(DIS a,DIS b)
{
    return a.s < b.s;
}
int main()
{
    int n,l;
    scanf("%d%d",&n,&l);
    for (int i = 1; i <= n; i++)
    {
        scanf("%d%d",&dis[i].s,&dis[i].e);
    }
    sort(dis + 1, dis + 1 + n,cmp);
    int sum = 0;//sum表示总共需要的木板
    int length = 0;
    for (int i = 1; i <= n; i++)
    {
        if (length >= dis[i].e)//如果当前长度大于泥坑的末端,则上一块木板可以铺完,continue;
            continue;
        length = max(dis[i].s,length);//否则看是否铺开新的泥坑。即比较当前长度和下一个泥坑开始的长度。
        while (length < dis[i].e)//这里就是铺下一个泥坑,直到当前长度铺完当前长度的泥坑。
        {
            sum += 1;
            length += l;
        }
    }
    printf("%d\n",sum);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值