Muddy roads POJ - 2437

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools. 

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely. 

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.
Input
* Line 1: Two space-separated integers: N and L 

* Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap. 
Output
* Line 1: The miminum number of planks FJ needs to use.
Sample Input
3 3
1 6
13 17
8 12

Sample Output

5

题目大意:拿给定长度的木板,去填坑,求最少的木板数量。

思路,一道贪心题目,因为不可能有重叠的坑,所以依据每个坑的起点排下序,然后从第一个坑开始填,把填完一个坑木板右端的位置记录下来去跟下一个坑的终点比较,如果大于终点则直接填下一个坑,如果下于终点就跟起点比较,如果大于起点,就把起点的值变为木板右端的值。(以前写这道题,用的排序是插入排序,是自己写的,现在会了sort)

ac代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
    int a[10005],b[10005];
};
int n,len;
int main()
{
    struct node stu;
    while(scanf("%d%d",&n,&len)==2&&n&&len)
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&stu.a[i],&stu.b[i]);
        sort(stu.a,(stu.a)+n);
        sort(stu.b,(stu.b)+n);
        int k=0,sum=0,tmp;
        for(int i=0;i<n;i++)
        {
            if(k>=stu.b[i])
            continue;
            if(k>stu.a[i])
                stu.a[i]=k;
            tmp=((stu.b[i]-stu.a[i])-1)/len+1;
            sum+=tmp;
            k=stu.a[i]+len*tmp;
        }
        printf("%d\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值