O - 螺旋方阵

Description

n×n的螺旋方阵当n=5和n=3时分别是如下的形式  

   
请给出一个程序,对于任意的输入n(0<n<11),输出按照上面规律所获得的n×n的螺旋方阵。

Input

输入第一行为整数m(0<m<10),代表有m组输入;  
接下来是m行数据,每行输入一个n(0<n<11)。

Output

按照输入的次序,依次输出每一个n×n方阵(一个方阵的同一行数据之间以'\t'分隔)  
两个输出方阵之间输出一个空行。

Sample Input

1
4

Sample Output

1   2   3   4
12  13   14   5
11  16   15   6
10   9    8   7

 

解题思路:

这道题还是不好找思路的,通过与递归地推联系发现可以对方阵一圈一圈的递归,参数是数组,当前数值now和当前圈数c,将当前值一个个放入数组中,直到now=n*n,然后递归下一圈,

如图:

细节处理:

对于递归边界,和输出格式都需注意

代码:

#include<iostream>
#include<vector>
#include<set>
#include<algorithm>
#include<cstdio>
using namespace std;
int n;
void screw(int a[15][15],int now,int c)
{
    if((now-1)!=n*n) {
    int i;
    for(i=c+1;i<=n-c;i++)
    {a[c+1][i]=now; now++;}
    for(i=c+2;i<=n-c;i++)
    {a[i][n-c]=now; now++;}
    for(i=n-c-1;i>=c+1;i--)
    {a[n-c][i]=now; now++;}
    for(i=n-c-1;i>=c+2;i--)
    {a[i][c+1]=now; now++;}
    screw(a,now,c+1);}
}
int main()
{
    int m,i,j,e0=0;
    int a[15][15];
    while(cin>>m)
    {
        for(i=0;i<m;i++)
        {
            if(e0==1) {cout<<endl; }
            e0=1;
            cin>>n;
            screw(a,1,0);
        for(int r=1;r<=n;r++)
        {
            for(j=1;j<n;j++)
            {cout<<a[r][j]<<'\t';}
            cout<<a[r][n]<<endl;
        }
        }
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值