What Kind of Friends Are You?

Japari Park is a large zoo home to extant species, endangered species, extinct species, cryptids and some legendary creatures. Due to a mysterious substance known as Sandstar, all the animals have become anthropomorphized into girls known as Friends.


Kaban is a young girl who finds herself in Japari Park with no memory of who she was or where she came from. Shy yet resourceful, she travels through Japari Park along with Serval to find out her identity while encountering more Friends along the way, and eventually discovers that she is a human.


However, Kaban soon finds that it's also important to identify other Friends. Her friend, Serval, enlightens Kaban that she can use some questions whose expected answers are either "yes" or "no" to identitfy a kind of Friends.


To be more specific, there are n Friends need to be identified. Kaban will ask each of them q same questions and collect their answers. For each question, she also gets a full list of animals' names that will give a "yes" answer to that question (and those animals who are not in the list will give a "no" answer to that question), so it's possible to determine the name of a Friends by combining the answers and the lists together.


But the work is too heavy for Kaban. Can you help her to finish it?


Input


There are multiple test cases. The first line of the input is an integer T (1 ≤ T ≤ 100), indicating the number of test cases. Then T test cases follow.


The first line of each test case contains two integers n (1 ≤ n ≤ 100) and q (1 ≤ q ≤ 21), indicating the number of Friends need to be identified and the number of questions.


The next line contains an integer c (1 ≤ c ≤ 200) followed by c strings p1, p2, ... , pc (1 ≤ |pi| ≤ 20), indicating all known names of Friends.


For the next q lines, the i-th line contains an integer mi (0 ≤ mi ≤ c) followed by mi strings si, 1, si, 2, ... , si, mi (1 ≤ |si, j| ≤ 20), indicating the number of Friends and their names, who will give a "yes" answer to the i-th question. It's guaranteed that all the names appear in the known names of Friends.


For the following n lines, the i-th line contains q integers ai, 1, ai, 2, ... , ai, q (0 ≤ ai, j ≤ 1), indicating the answer (0 means "no", and 1 means "yes") to the j-th question given by the i-th Friends need to be identified.


It's guaranteed that all the names in the input consist of only uppercase and lowercase English letters.


Output


For each test case output n lines. If Kaban can determine the name of the i-th Friends need to be identified, print the name on the i-th line. Otherwise, print "Let's go to the library!!" (without quotes) on the i-th line instead.


Sample Input


2
3 4
5 Serval Raccoon Fennec Alpaca Moose
4 Serval Raccoon Alpaca Moose
1 Serval
1 Fennec
1 Serval
1 1 0 1
0 0 0 0
1 0 0 0
5 5
11 A B C D E F G H I J K
3 A B K
4 A B D E
5 A B K D E
10 A B K D E F G H I J
4 B D E K
0 0 1 1 1
1 0 1 0 1
1 1 1 1 1
0 0 1 0 1
1 0 1 1 1
Sample Output


Serval
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
B
Let's go to the library!!
K
Hint


The explanation for the first sample test case is given as follows:


As Serval is the only known animal who gives a "yes" answer to the 1st, 2nd and 4th question, and gives a "no" answer to the 3rd question, we output "Serval" (without quotes) on the first line.


As no animal is known to give a "no" answer to all the questions, we output "Let's go to the library!!" (without quotes) on the second line.


Both Alpaca and Moose give a "yes" answer to the 1st question, and a "no" answer to the 2nd, 3rd and 4th question. So we can't determine the name of the third Friends need to be identified, and output "Let's go to the library!!" (without quotes) on the third line.

解题思路:

构造矩阵,使行代表问题,列代表所有friends,对于矩阵初始值全为0,用map给friends编号1~c,下面就是对于每个问题给出yes的同学,令对应矩阵中的点的值为1,然后就是对于输入的矩阵来筛选friends(筛选n个),设置数组a,初始值全为0,对于每个问题与要求答案不相符的同学的值--,最后如果有小于等于1个同学没有--过输出该同学的名字

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
	//freopen("aa.txt","r",stdin);
	int t,n,m,q,c,i,j,k;
	cin>>t;
	while(t--)
	{
		cin>>n>>q;
		cin>>c;
		bool b[300][300]={0};
		
		map<string,int>name;
		string s[300];
		string ss;
		for(i=1;i<=c;i++)
		{
			cin>>s[i];
			name[s[i]]=i;
		}
		for(i=1;i<=q;i++)
		{
			cin>>m;
			for(j=1;j<=m;j++)
			{
				cin>>ss;
				b[i][name[ss]]=1;
			}
		}
		bool bb;
		for(i=1;i<=n;i++)
		{
			int a[300]={0};
			for(j=1;j<=q;j++)
			{
				cin>>bb;
				for(k=1;k<=c;k++)
				{
					if(b[j][k]!=bb)
						a[k]--;
				}
			}
			int xx=0,yy=0;
			for(k=1;k<=c;k++)
			{
				if(a[k]==0)
				{
					xx=k;
					yy++;
				 } 
			}
			if(yy==0||yy>1)
				cout<<"Let's go to the library!!"<<endl;
			else 
				cout<<s[xx]<<endl;
		}
		
	}
	
	
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值