ACM-ICPC国际大学生程序设计竞赛北京赛区(2017)网络赛-题目1 : Visiting Peking University

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述

Ming is going to travel for n days and the date of these days can be represented by n integers: 0, 1, 2, …, n-1. He plans to spend m consecutive days(2 ≤ m ≤ n)in Beijing. During these m days, he intends to use the first day and another day to visit Peking university. Before he made his plan, Ming investigated on the number of tourists who would be waiting in line to enter Peking university during his n-day trip, and the results could be represented by an integer sequence p[i] (0 ≤ i ≤ n-1, p[i] represents the number of waiting tourists on day i). To save time, he hopes to choose two certain dates a and b to visit PKU(0 ≤ a < b ≤ n-1), which makes p[a] + p[b] as small as possible.

Unfortunately, Ming comes to know that traffic control will be taking place in Beijing on some days during his n-day trip, and he won’t be able to visit any place in Beijing, including PKU, on a traffic control day. Ming loves Beijing and he wants to make sure that m days can be used to visit interesting places in Beijing. So Ming made a decision:  spending k (m ≤ k ≤ n) consecutive days in Beijing is also acceptable if there are k - m traffic control days among those k days. Under this complicated situation, he doesn’t know how to make the best schedule. Please write a program to help Ming determine the best dates of the two days to visit Peking University.  Data guarantees a unique solution.

输入

There are no more than 20 test cases.

For each test case:

The first line contains two integers, above mentioned n and m (2 ≤ n ≤ 100, 2 ≤ m ≤ n).

The second line contains n integers, above mentioned p[0] , p[1] , … p[n-1]. (0 ≤ p[i] ≤ 1000, i = 0 ... n-1)

The third line is an integer q (0 ≤ q ≤ n), representing the total number of traffic control days during the n-day trip, followed by q integers representing the dates of these days.

输出

One line, including two integers a and b, representing the best dates for visiting PKU.

样例输入
7 3
6 9 10 1 0 8 35
3 5 6 2
4 2
10 11 1 2
1 2
样例输出
0 3
1 3

题意:小明要旅游n天,这n天分别是0,1,2...n-1,本来小明要在北京玩连续m天,并且在北京的m天里,要用第一天和另外一天总共两天的时间去PKU玩,而且小明知道了PKU在n天里的排队人数p[i],此时只要找排队人数最少的一天加上第一天那么去PKU的两天就确定了,但是北京有交通限制,交通限制时不能去PKU玩,而且给出了北京在哪些天是的交通限制的,在此情况下小明无法保证在北京连续玩m天,但是小明放低要求,它愿意在北京连续k天只要这k天里有m天是不限制的,让求出去PKU的最佳方案。

代码: 

#include <iostream>
#include <stdio.h>
#include <cstring>
using namespace std;

int main()
{
    int N, M;
    int p[110];
    int vis[110];
    int t, d, k;
    int ans, sum, si, ei;
    while(~scanf("%d%d", &N, &M))
    {
        memset(vis, 0, sizeof(vis));
        for(int i=0; i<N; i++)
        {
            scanf("%d", &p[i]);
        }
        scanf("%d", &t);
        for(int i=0; i<t; i++)
        {
            scanf("%d", &d);
            vis[d]=1;
        }
        ans=1e9;//极大值
        for(int i=0; i<N; i++)//第i天开始在北京
        {
            if(vis[i]==1)//t--   还剩 t 天管制
            {
                t--;
                continue;
            }
            if(i+M+t>N)//剩余天数不足
            {
                continue;
            }
            k=i+M;//可以忍受在北京待k天
            sum=p[i];//第一天去
            int minn=1e9;
            int mins, mine;//去PKU的两天
            mins=i;//第一天
            for(int j=i+1; j<k; j++)
            {
                if(vis[j]==1)//管制
                {
                    k++;
                    continue;
                }
                if(minn>p[j])
                {
                    minn=p[j];
                    mine=j;
                }
            }
            sum+=minn;
            if(ans>sum)
            {
                ans=sum;
                si=mins;
                ei=mine;
            }
        }
        printf("%d %d\n", si, ei);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值