POJ - 1845 - Sumdiv-(数论,唯一分解定理,约数和公式,用递归二分求等比数列,快速幂)

Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).
Input
The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.
Output
The only line of the output will contain S modulo 9901.
Sample Input
2 3
Sample Output
15
Hint
2^3 = 8. 
The natural divisors of 8 are: 1,2,4,8. Their sum is 15. 
15 modulo 9901 is 15 (that should be output). 

题意:给出A,B让求A^B的所有因子的和

用到许多公式:数学公式

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
#define mod 9901
#define M 10000

ll power(ll d,ll p)//幂次的优化
{
    ll ans=1;
    while(p>0)
    {
        if(p%2)
            ans=(ans*d)%mod;
        p/=2;
        d=(d*d)%mod;
    }
    return ans;
}

ll sum(ll d,ll p)//等比数列求和递归
{
    if(p==0)
        return 1;
    if(p==1)
        return 1+d;
    if(p%2==1)
        return sum(d,p/2)*(1+power(d,p/2+1))%mod;
    else return (sum(d,p/2-1)*(1+power(d,p/2))%mod+power(d,p))%mod;
}

int main()
{
    int i,j;
    int a,b;
    while(~scanf("%d%d",&a,&b))
    {
        int ds[M]; //存因子
        int po[M]; //存对应因子的个数
        int tt=0;
        for(i=2;i*i<=a;)//求a的因子
        {
            if(a%i==0)
            {
                ds[tt]=i;
                po[tt]=0;
                while(!(a%i))
                {
                    po[tt]++;
                    a/=i;
                }
                tt++;
            }
            i==2?i++:i+=2;
        }
        if(a!=1)
        {
            ds[tt]=a;
            po[tt++]=1;
        }
        ll ans = 1;
        for(i=0;i<tt;i++)
            ans=(ans*(ll)sum(ds[i],po[i]*b))%mod;
        printf("%I64d\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值