HDU Problem e

Problem Description
Mr. West bought a new car! So he is travelling around the city.<br><br>One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.<br><br>Can Mr. West go across the corner?<br><img src=../../../data/images/2438-1.jpg><br>
 

Input
Every line has four real numbers, x, y, l and w.<br>Proceed to the end of file.<br>
 

Output
If he can go across the corner, print "yes". Print "no" otherwise.<br>
 

Sample Input
 
 
10 6 13.5 4
10 6 14.5 4
 

Sample Output
 
 
yesno

题意:一辆汽车原先在宽度为x的街道上走,现在有转弯到宽度为y的街道上去,车长l 宽 w;问是否能转弯

思路:极限加,二分,

极限:转弯时车后面一直紧贴原先道路的路边(这样做容易转,自己想像一下实际情况)

二分转弯的角度,并计算转弯时的最长的车身(斜着的车身)是否比y短

计算公式:

s=l*cos(m)+w*sin(m)-x;

    h=s*tan(m)+w*cos(m);

图示:


code:

#include<bits/stdc++.h>
using namespace std;
double pi=4*atan(1);
double x,y,l,w;
double suan(double x);
int main()
{
    while(cin>>x>>y>>l>>w)
    {
        if(w>y)
        {
            cout<<"no"<<endl;
            continue;
        }
        double l=0;
        double r=pi/2;
        double mid,emid;
        while(r-l>0.0000001)
        {
            mid=(l+r)/2;
            emid=(mid+r)/2;
            if(suan(mid)>suan(emid))
              r=emid;
            else
              l=mid;
        }
        if(suan(mid)<=y)
          cout<<"yes"<<endl;
        else
          cout<<"no"<<endl;
    }
    return 0;
}
double suan(double m)//求高度的公式,表示没怎么看懂,
//应该有极限的思想在里面:一直贴着开始街道的一边
{
    double s,h;
    s=l*cos(m)+w*sin(m)-x;
    h=s*tan(m)+w*cos(m);
    return h;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值