Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?<br>
Input
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
Sample Input
5 1 5 3 3 1 2 5 0
Sample Output
3
中文题意:奇怪的电梯
思路:
dfs深搜每一层电梯的上下移动,查看能否到达
code:
#include <cstdio>
using namespace std;
const int MAX=202;
int f[MAX],ans;
int d[MAX];
int n,a,b;
void dfs(int s,int cnt)
{
if(s>n||s<1)//判断是否能这样走
return;
if(s==b)
{
if(cnt<ans)
{
ans=cnt;
return;
}
}
if(cnt>=d[s])//检查是否走过
return;
d[s]=cnt;//记录已走过
dfs(s+f[s],cnt+1);//向上走
dfs(s-f[s],cnt+1);//向下走
}
int main()
{
while(~scanf("%d",&n)&& n)
{
scanf("%d %d",&a,&b);
for(int i=1; i<=n; ++i)
{
scanf("%d",&f[i]);
d[i]=MAX;
}
ans=MAX;
dfs(a,0);
if(ans==MAX)
{
printf("-1\n");
}
else
{
printf("%d\n",ans);
}
}
return 0;
}
//完美的代码