HDU-1425 sort

sort

Time Limit: 6000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 76053    Accepted Submission(s): 19980


 

Problem Description

给你n个整数,请按从大到小的顺序输出其中前m大的数。

 

 

Input

每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。

 

 

Output

对每组测试数据按从大到小的顺序输出前m大的数。

 

 

Sample Input

 

5 3 3 -35 92 213 -644

 

 

Sample Output

 
213 92 3

Hint

请用VC/VC++提交

 

 

Author

LL

 

 

Source

ACM暑期集训队练习赛(三)

 

 

Recommend

linle

 

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1425

 

AC的C++代码

/* HDU - 1425 */ 
/* 桶排序 */

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int N = 1e6;
const int M = 500000;
int a[N+1];

int main(void)
{
	int n,m,c;
	while(scanf("%d%d",&n,&m) != EOF){
		memset(a,0,sizeof(a));
		
		while(n--){
			scanf("%d",&c);
			a[c+M]++;
		}
		
		
		for(int i=0, j=N; i<m; j--){//注意这个循环的格式 
			while(a[j] && i<m){
				if(i){
					printf(" ");
				}
				printf("%d",j-M);
				i++;
				a[j]--;
			}
		}
		
		printf("\n");
		
	}
	
	
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值