NY879大水比

Consecutive sum II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 2
描述

Consecutive sum come again. 
1    = 0 + 1
2+3+4    = 1 + 8
5+6+7+8+9  = 8 + 27

You can see the consecutive sum can be representing like that. The nth line will have 2*n+1 consecutive numbers on the left, the first number on the right equal with the second number in last line, and the sum of left numbers equal with two number’s sum on the right.
Your task is that tell me the right numbers in the nth line.

输入
The first integer is T, and T lines will follow.
Each line will contain an integer N (0 <= N <= 20000).
输出
For each case, output the right numbers in the Nth line.
All answer in the range of signed 64-bits integer.
样例输入
3012
样例输出
0 11 88 27
上传者

ACM_吕德铭



import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		 int n=in.nextInt();
		 for(int i=0;i<n;i++){
			 long m=in.nextLong();
			 long mm=m+1;
			 long a1=m*m*m;
			 long a2=mm*mm*mm;
			 System.out.println(a1+" "+a2); 
		 }
		
	}
			
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值