Lake Counting
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 27328 | Accepted: 13730 |
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12 W........WW. .WWW.....WWW ....WW...WW. .........WW. .........W.. ..W......W.. .W.W.....WW. W.W.W.....W. .W.W......W. ..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
深搜,记录一下深搜的次数就可以了
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
深搜,记录一下深搜的次数就可以了
#include <stdio.h>
int n,m;
char map[101][101];
void dfs(int i,int j)
{
if(i>=0&&j>=0&&i<n&&j<m&&map[i][j]=='W')
{
map[i][j]='.';
dfs(i,j+1);
dfs(i,j-1);
dfs(i+1,j);
dfs(i-1,j);
dfs(i-1,j-1);
dfs(i-1,j+1);
dfs(i+1,j-1);
dfs(i+1,j+1);
}
}
int main()
{
int i,j,count;
count=0;
scanf("%d%d",&n,&m);
getchar();
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
scanf("%c",&map[i][j]);
}
getchar();
}
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
if(map[i][j]=='W')
{
dfs(i,j);
count++;
}
}
}
printf("%d\n",count);
return 0;
}