POJ 3268 Silver Cow Party

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17213 Accepted: 7861

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

奶牛派对:有分别来自 N 个农场的 N 头牛去农场 X 嗨皮,农场间由 M 条有向路径连接。每头牛来回都挑最短的路走,求它们走的路的最大长度?

求两次最短路,第一次求x到其余各点的最短路,第二次求各点到x的最短路。前者易于解决,直接应用spfa或其他最短路算法即可,后者要先将邻接矩阵转置再执行最短路算法。
为什么进行矩阵转置?比如u(u != x)到x的最短路为<u,v1>,<v1,v2>,<v2,v3>,...,<vi, x>,这条路径在转置邻接矩阵后变成<x,vi>,...,<v3,v2>,<v2, v1>,<v1,u>.于是乎,在转置邻接矩阵后,执行最短路算法求出x到u的最短路<x,vi>,...,<v3,v2>,<v2, v1>,<v1,u>即可得到转置前u到x的最短路。


#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
using namespace std;
int N, M, X;
struct node
{
	int to;
	int w;
}t;
vector<node>map[1005];
vector<node>rmap[1005];
int dist[1005];
int rdist[1005];
bool vis[1005];
void dijkstra()
{
	int i, j, f, min;
	memset(dist, 0x3f, sizeof(dist));
	memset(vis, false, sizeof(vis));
	dist[X] = 0;
	for(i = 1; i <= N; i++)
	{
		f = -1;
		min = 0x3f3f3f3f;
		for(j = 1; j <= N; j++)
			if(!vis[j] && min > dist[j])
				min = dist[f = j];
		if(f == -1) break;
		vis[f] = true;
		for(j = 0; j < map[f].size(); j++)
			if(!vis[map[f][j].to] && dist[f] + map[f][j].w < dist[map[f][j].to])
				dist[map[f][j].to] = dist[f] + map[f][j].w;
	}
}
int main()
{
	int i, A, B, T, max;
	while(scanf("%d%d%d", &N, &M, &X) != EOF)
	{
		for(i = 1; i <= M; i++)
		{
			scanf("%d%d%d", &A, &B, &T);
			t.w = T;
			t.to = B;
			map[A].push_back(t);
			t.to = A;
			rmap[B].push_back(t);
		}
		dijkstra();
		memcpy(rdist, dist, sizeof(dist));
		for(i = 1; i <= N; i++)
			map[i] = rmap[i];
		dijkstra();
		for(i = 1; i <= N; i++)
			dist[i] += rdist[i];
		max = 0;
		for(i = 1; i <= N; i++)
			if(dist[i] < 0x3f3f3f3f && dist[i] > max)
				max = dist[i];
		printf("%d\n", max);
		for(i = 1; i <= N; i++)
		{
			map[i].clear();
			rmap[i].clear();
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值