poj2352 Stars (树状数组)

30 篇文章 0 订阅
28 篇文章 0 订阅

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30541 Accepted: 13340

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.  

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.  

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.  

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source


今天复习一下树状数组,最近都在看线段树和树状数组,还是不能灵活运用啊!!!这道感觉很好用树状数组;
题目的意思就是把在一个平面坐标上,问在一点的左下方的点有多少个,有多少个就是几级,在x轴相等的情况下就看它左边,看题目给出来的例子,5的左下方(x比它小,y小于或等于它的),所以5下面的就是1,2,4就属于三级,3的前面有1,2所以就属于2级,2和4前面就只有1所以就属于1级,1前面没有就属于0级;
按照题目的输入,当前的星星就和后面的星星没有关系,只跟前面的区间段有关,这里就可以用树状数组;
感觉线段树的应用范围比树状数组广,可以用树状数组做的题基本上都可以用线段树做;
下面是ac的代码;
#include <stdio.h>
#define N 32002
int levels[N];//储存星星的等级
int c[N];//树状数组
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)//求和
{
    int temp=0;
    while(x>0)
    {
        temp+=c[x];
        x-=lowbit(x);
    }
    return temp;
}
void update(int x)//更新
{
    while(x<=N)
    {
        c[x]++;
        x+=lowbit(x);
    }
}
int main()
{
   int n,x,y;
   scanf("%d",&n);
  for(int i=1;i<=n;i++)
  {
      scanf("%d%d",&x,&y);
      levels[sum(x+1)]++;//这里主要是要防止x=0的情况,给所有的横坐标都加1
      update(x+1);
  }
  for(int i=0;i<n;i++)
    printf("%d\n",levels[i]);
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值