The Best Seat in ACM Contest

比赛简单题

1、点击打开链接

2、.题目:

The Best Seat in ACM Contest

Time Limit: 1000MS Memory limit: 65536K

题目描述

Cainiao is a university student who loves ACM contest very much. It is a festival for him once when he attends ACM Asia Regional Contest because he always can find some famous ACMers there.
Cainiao attended Asia Regional Contest Fuzhou Site on November 20, 2011. After he got seat map, he wanted to know which seat is the best one.
Cainiao have joined so many QQ Group about ACM/ICPC that he is almost familiar with the strength of each team. In his mind, the value of a seat is defined as following:

1. Strength of each team can be expressed as a positive integer.
2. The value of a seat is related to the adjacent seat (up/down/left/right, only four directions being considering).
3. For an adjacent seat, if the strength of this team is stronger than yours, the absolute value of difference of two teams should be added to your seat, otherwise, the absolute value of difference should be subtracted from your seat.
4. If the adjacent seat is empty (which means you are located at the most left/right/up/down), the value of your seat should be subtracted 1.
5. The best one in a contest is the seat that has the highest value.
6. The initial value of the seat is ZERO.

For example, there are 12 ( 3 X 4 ) teams in a contest, the strength of each team is as figure (a), and then you can calculate the value of each seat as figure (b).

 

输入

Input contain a positive integer T( T <=50 ) in the first line, which means T cases.
The first line of each case contains two positive integers N and M (3 <= N, M <= 20) which means the row and column number of the teams, then N rows following, each line contains M positive integers that represent the strengths of the teams.

输出

For each case, first output the case number, and then output the value and row number and column number of the best seat in one line for each case. 
If there are multiple solutions for one case, you should output the seat whose row number is largest and only output the seat whose column number is largest if still overlapping.

示例输入

13 41 5 3 46 3 3 44 3 2 1

示例输出

Case 1: 7 1 1

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[25][25];
int b[25][25];
struct node
{
    int s;
    int x;
    int y;
} c[410];
int cmp(node a,node b)
{
    if(a.s!=b.s)
        return a.s>b.s;
    else if(a.x!=b.x)
        return a.x>b.x;
    else
        return a.y>b.y;
}
int main()
{
    int t,n,m;
    scanf("%d",&t);
    for(int cas=1; cas<=t; cas++)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
                scanf("%d",&a[i][j]);
        }
        int k=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if((i==1&&j==1)||(i==1&&j==m)||(i==n&&j==1)||(i==n&&j==m))
                {
                    b[i][j]--;
                }
                if(i==1||i==n||j==1||j==m)
                    b[i][j]--; 
                if((a[i-1][j]>a[i][j])&&i-1>=1)
                    b[i][j]+=(a[i-1][j]-a[i][j]);
                if((a[i-1][j]<a[i][j])&&i-1>=1)
                    b[i][j]+=(a[i-1][j]-a[i][j]);
                if((a[i+1][j]>a[i][j])&&i+1<=n)
                    b[i][j]+=(a[i+1][j]-a[i][j]);
                if((a[i+1][j]<a[i][j])&&i+1<=n)
                    b[i][j]+=(a[i+1][j]-a[i][j]);
                if((a[i][j-1]>a[i][j])&&j-1>=1)
                    b[i][j]+=(a[i][j-1]-a[i][j]);
                if((a[i][j-1]<a[i][j])&&j-1>=1)
                    b[i][j]+=(a[i][j-1]-a[i][j]);
                if((a[i][j+1]>a[i][j])&&j+1<=m)
                    b[i][j]+=a[i][j+1]-a[i][j];
                if((a[i][j+1]<a[i][j])&&j+1<=m)
                    b[i][j]+=a[i][j+1]-a[i][j];
                c[k].s=b[i][j];
                c[k].x=i;
                c[k].y=j;
                k++;
            }
        }
        sort(c,c+k,cmp);
        printf("Case %d: %d %d %d\n",cas,c[0].s,c[0].x,c[0].y);
    }
    return 0;
}
/*
1
3 4
1 5 3 4
6 3 3 4
4 3 2 1
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值