山东省第八届ACM省赛 K 题(CF)

Problem Description

LYD loves codeforces since there are many Russian contests. In an contest lasting for T minutes there are n problems, and for the ith problem you can get aiditi points, where ai indicates the initial points, di indicates the points decreased per minute (count from the beginning of the contest), and ti stands for the passed minutes when you solved the problem (count from the begining of the contest).
Now you know LYD can solve the ith problem in ci minutes. He can't perform as a multi-core processor, so he can think of only one problem at a moment. Can you help him get as many points as he can?

Input

The first line contains two integers n,T(0≤n≤2000,0≤T≤5000).
The second line contains n integers a1,a2,..,an(0<ai≤6000).
The third line contains n integers d1,d2,..,dn(0<di≤50).
The forth line contains n integers c1,c2,..,cn(0<ci≤400).

Output

Output an integer in a single line, indicating the maximum points LYD can get.

Example Input
3 10
100 200 250
5 6 7
2 4 10
Example Output
254


题意:LYD要打CF,一共n道题,t单位时间,每道题都有初始分数a,每单位时间减的分数d和做出这道题需要多长时间c,求最大的得分;

思路:01背包,先把每道题的d/c按从大到小排序,先取减分最快的,做一边01背包就行了;

ps:后悔了,没想到这道题这么简单,当时比赛的时候没做。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define INF 0x3f3f3f3f
#define maxn 2010
using namespace std;
int n,t;
int dp[5050];
struct edge
{
    int a,d,c;
    double f;
};
bool cmp(edge x,edge y)
{
    return x.f>y.f;
}
edge g[maxn];
int main()
{
    memset(dp,0,sizeof(dp));
    scanf("%d%d",&n,&t);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&g[i].a);
    }
    for(int i=0; i<n; i++)
    {
        scanf("%d",&g[i].d);
    }
    for(int i=0; i<n; i++)
    {
        scanf("%d",&g[i].c);
        g[i].f=1.0*g[i].d/g[i].c;
    }
    sort(g,g+n,cmp);
    for(int i=0; i<n; i++)
    {
        for(int j=t; j>=g[i].c; j--)
        {
            dp[j]=max(dp[j],dp[j-g[i].c]+g[i].a-g[i].d*j);
        }
    }
    int MAX=-INF;
    for(int i=0; i<=t; i++)
    {
        if(MAX<dp[i]) MAX=dp[i];
    }
    cout<<MAX<<endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值