2、题目大意:给定一根已知长度的木棍,给定n个切割点,要求按照切割点切割木棍,花费按照切割的木棍长度计算,例如有一根长10的木棍,切割点为2、4、7,如果按照2、4、7的顺序切割,花费将是10 + 8 + 6 = 24,如果按照4、2、7的顺序切割,那么花费将是10 + 4 + 6 = 20,切割顺序可以任意,要求花费最小
3、这是一道区间Dp的问题,不过还是没能自己写出状态转移方程,努力中。。。。
题目:
Cutting Sticks |
You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.
It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.
Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.
Input
The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n < 50) of cuts to be made.
The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.
Sample Input
100 3 25 50 75 10 4 4 5 7 8 0
Sample Output
The minimum cutting is 200. The minimum cutting is 22.
4、ac代码:
#include<stdio.h>
#define N 55
#include<string.h>
int cut[N];
int len,n;
int dp[N][N];
void DP()
{
int temp;
memset(dp,0,sizeof(dp));
for(int p=1;p<=n+1;p++)//段
{
for(int i=0;i<=n+1-p;i++)//起始点
{
int j=i+p;//终点
int min=99999;
for(int k=i+1;k<j;k++)
{
temp=dp[i][k]+dp[k][j]+cut[j]-cut[i];
if(temp<min)
{
min=temp;
}
}
if(min!=99999)
dp[i][j]=min;//更新
}
}
printf("The minimum cutting is %d.\n",dp[0][n+1]);
}
int main()
{
while(scanf("%d",&len)!=EOF)
{
if(len==0)
break;
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&cut[i]);
cut[0]=0;
cut[n+1]=len;
//printf("****");
DP();
}
return 0;
}