uva10003 Cutting Sticks 经典dP,表达式上的动态规划

26 篇文章 0 订阅

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input
The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n < 50) of cuts to be made.

The next line consists of n positive numbers ci ( 0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.

An input case with l = 0 will represent the end of the input.

Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input

100
3
25 50 75
10
4
4 5 7 8
0

Sample Output

The minimum cutting is 200.
The minimum cutting is 22.

Miguel Revilla
2000-08-21

/*
Author:ZCC;
Solve:类似最优矩阵乘法。
木棍的总端点数量为n+2个(n个被切位置加木棍首尾),用ai代表第i个端点,木棍只能在其端点处被分割。
定义状态d(i,j),代表切割端点i到端点j的木棍的最小花费。
状态转移方程:d(i,j) = min{ d(i,k) + d(k+j) + a[j]-a[i] | i<k<j }
根据计算需求,需要按照j-i递增的顺序递推(因为大区间依赖于小区间的值,刘汝佳白书所讲),首先升序枚举状态首尾两端点的间隔,然后枚举起点,计算所有状态,d(0,n+1)为最终解。
f(i,j)=min{f(i,k)+f(k,j)+len(j)-len(i)}(i<k<j)

*/
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<stack>
#include<string>
#include<fstream>
#define pb(s) push_back(s)
#define cl(a,b) memset(a,b,sizeof(a))
#define bug printf("===\n");
using namespace std;
typedef vector<int> VI;
#define rep(a,b) for(int i=a;i<b;i++)
#define rep_(a,b) for(int i=a;i<=b;i++)
#define P pair<int,int>
#define bug printf("===\n");
#define PL(x) push_back(x)
void max(int&a,int b){if(a<b)a=b;}
const int maxn=1005;
const int inf=999999;
typedef long long LL;

int sticks;
int n,a[maxn];
int dp[maxn][maxn];
int main(){

    while(scanf("%d",&sticks)&&sticks){
        scanf("%d",&n);
        a[0]=0;
        for(int i=1;i<=n;i++){
            scanf("%d",a+i);
        }
        a[n+1]=sticks;
        cl(dp,0);
        //刘汝佳说过 必须按j-i递增的顺序枚举
        for(int t=2;t<=n+1;t++){//枚举j与i间的间隔
            for(int i=0;i<=n+1;i++){//起点
                int j=i+t;//终点
                for(int k=i+1;k<j;k++){
                    if(!dp[i][j])dp[i][j]=dp[i][k]+dp[k][j]+a[j]-a[i];else
                    dp[i][j]=min(dp[i][k]+dp[k][j]+a[j]-a[i],dp[i][j]);
                }
            }
        }
        printf("The minimum cutting is %d.\n",dp[0][n+1]);

    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值