POJ-3278 Catch That Cow (C++)

POJ-3278 Catch That Cow (C++)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

my analysis

This problem is essentially given n, through three kinds of specified operation to get k, and to ensure the minimum number of operations, direct BFS breadth first search can be, similar to Luo Gu’s “strange elevator” problem.

solution(C++)

#include<iostream>
#include<queue>
using namespace std;
int N, K;
bool inq[200000] = { false };
int step[200000] = { 0 };
int BFS()
{
	queue<int> q;
	q.push(N);
	while (!q.empty())
	{
		int top = q.front();
		q.pop();
		if (top == K)
			return step[top];
		if (top - 1 >= 0 && inq[top - 1] == false)
		{
			q.push(top - 1);
			step[top - 1] = step[top] + 1;
			inq[top - 1] = true;
		}
		if (top + 1 <= 100000 && inq[top + 1] == false)
		{
			q.push(top + 1);
			step[top + 1] = step[top] + 1;
			inq[top + 1] = true;
		}
		if (top * 2 <= 100000 && inq[top * 2] == false)
		{
			q.push(top * 2);
			step[top * 2] = step[top] + 1;
			inq[top * 2] = true;
		}
	}
	return -1;
}
int main()
{
	cin >> N >> K;
	cout << BFS() << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值