POJ 1129 - Channel Allocation

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14326 Accepted: 7302

Description

When a radio station is broadcasting over a very large area, repeaters are used to  retransmit (转播) the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not  interfere (干涉) with one another. This condition is satisfied if  adjacent (邻近的) repeaters use different channels.

Since the radio  frequency (频率)  spectrum (光谱) is a precious resource, the number of channels required by a given network of repeaters should be  minimised (使缩到最小). You have to write a program that reads in a description of a repeater network and determines the  minimum (最小的) number of channels required.

Input

The  input (投入) consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive (连贯的)  upper-case (大写) letters of the  alphabet (字母表) starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters  indicates (表明) the end of input.

Following the number of repeaters is a list of  adjacency (毗邻) relationships. Each line has the form:

A:BCDH

which  indicates (表明) that the repeaters B, C, D and H are  adjacent (邻近的) to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in  alphabetical (字母的) order.

Note that the adjacency is a  symmetric (对称的) relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the  graph (图表) formed by connecting adjacent repeaters does not have any line  segments (段) that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels  interfere (干涉). The  sample (试样的)  output (输出) shows the format of this line. Take care that channels is in the  singular (单数的) form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed.
Analysis
这个题的意思是一个无线广播需要一些中继器,但是相邻的中继器如果使用同样的频率会有相互影响,给定所有的相邻关系,问最少使用几种频率可以使它们不相互影响。
为了更好的建模,我们可以把它转化为给一些点染色,同时使相邻的点染不同的颜色,最少需要几种颜色。
用一个结构体数组存储与每个点相邻的点,枚举每个点,将这个点的相邻的点的颜色标记,然后再枚举这个点的颜色,找到第一个(也就是最小的)没有被标记的颜色,就是这个点的颜色,最后找出最大的颜色编号就是答案。
详细见代码。。。
Source Code
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
struct node
{
	int color[27], t;
} p[27];
int color[36], vis[36];
int main()
{
	int n, i, j, l, ans;
	char s[30];
	while (~scanf("%d", &n) && n)
	{
		ans = 1;
		memset(color, 0, sizeof(color));
		for (i = 1; i <= n; i++)
		{
			scanf("%s", s);
			l = (int)strlen(s);
			p[i].t = 1;
			for (j = 2; j < l; j++)
				p[i].color[p[i].t++] = s[j] - 'A' + 1;
		}
		for (i = 1; i <= n; i++)
		{
			memset(vis, 0, sizeof(vis));
			for (j = 1; j < p[i].t; j++)
				vis[color[p[i].color[j]]] = color[p[i].color[j]];
			for (j = 1; j <= n; j++)
				if (!vis[j])
				{
					color[i] = j;
					break;
				}
			ans = max(ans, color[i]);
		}
		if (ans < 2)
			printf("1 channel needed.\n");
		else
			printf("%d channels needed.\n", ans);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值