Catch That Cow POJ - 3278

12 篇文章 0 订阅

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题意

给你n和k,对n进行三种操作,+1,-1,×2,求最少操作使n变为k

思路

本来以为使数学题,看题解才知道bfs,

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

queue<int> q;//队列
int vis[100100];//是否达到
int step[100100]; //达到此点最小步数
int bfs(int n,int k)
{
    int head,next;
    q.push(n);
    step[n] = 0;
    vis[n] = 1; 
    while(!q.empty())
    {
        head = q.front(); //取队首
        q.pop();        //弹出队首
        next = head-1;
        if(next>=0&&next<=100000&&!vis[next])
        {
            q.push(next);
            step[next] = step[head]+1;
            vis[next] = 1;
        }
        if(next==k) return step[next];
        next = head+1;
        if(next>=0&&next<=100000&&!vis[next])
        {
            q.push(next);
            step[next] = step[head]+1;
            vis[next] = 1;
        }
        if(next==k) return step[next];
        next = head*2;
        if(next>=0&&next<=100000&&!vis[next])
        {
           q.push(next);
            step[next] = step[head]+1;
            vis[next] = 1;
        }
        if(next==k) return step[next];
    }
}
int main()
{
    int n,k,i,j,ans,time;
    while(cin>>n>>k)
    {
        time=0;
        if(n>=k) {cout<<n-k<<endl;continue;} //最能-1
        memset(vis,0,sizeof(vis));
        ans = bfs(n,k);
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值