ACM刷题之POJ———— Catch That Cow

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 84879 Accepted: 26650

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


一道bfs题,注意判断条件放在前面,要写vis 否则会死循环

下面是ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<string>
#include<iostream>
using namespace std;
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int N=2e5+7;

typedef struct fi
{
	int dis;
	int bu;
	
}fi;

fi fam,now,temps;

queue<fi>q;
int n,x,cnt;
int vis[N];

void bfs()
{
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		temps=now;
		if(now.dis==x)
		{
			cnt=now.bu;
			break;
		}
		++now.bu;
		if(now.dis<x)
		{
			if(!vis[temps.dis*2])
			{
				now.dis=temps.dis*2;
				q.push(now);
				vis[now.dis]=1;
			}
			if(!vis[temps.dis+1])
			{
				now.dis= temps.dis+1;
				q.push(now);
				vis[now.dis]=1;
			}
			if(!vis[temps.dis-1])
			{
				now.dis= temps.dis-1;
				q.push(now);
				vis[now.dis]=1;
			}
		}else {
			
			if(!vis[temps.dis-1])
			{
				now.dis= temps.dis-1;
				q.push(now);
				vis[now.dis]=1;
			}
		}
		
		
	}
	
	
}

int main()
{
	//freopen("f:/input.txt", "r", stdin);
	int i,j;
	while(scanf("%d%d",&fam.dis,&x)!=EOF)
	{
		if(fam.dis==x)
		{
			printf("0\n");
			continue;
		}
		fam.bu=0;
		cnt=0;
		q.push(fam);
		CLR(vis,0);
		vis[fam.dis]=1;
		bfs();
		printf("%d\n",cnt);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值