Simple Problem with Integers POJ - 3468

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <cstring>
#include <queue>
#include <cmath>
#include <set>

//#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
ll a[110000]; //计算区间
ll tr[1100000]; //线段树区间 a的四倍 怕出错开十倍
ll lazy[1100000];//懒惰数组
void pushup(ll rt) //更新线段树rt的值
{
    tr[rt] = tr[rt<<1] +tr[rt<<1|1];
}
void build(ll l,ll r,ll rt) //建树 l r 为当前线段树rt 代表的区间和
{
    if(l==r)
    {
        tr[rt] = a[l];
        return ;
    }
    ll m =(l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    pushup(rt);
}
void pushdown(ll rt,ll ln,ll rn)   //更新rt
{
    if(lazy[rt]) //判断当前区间是否给标记
    {
        lazy[rt<<1] += lazy[rt];
        lazy[rt<<1|1] += lazy[rt];
        tr[rt<<1] += lazy[rt]*ln;
        tr[rt<<1|1] += lazy[rt]*rn;
        lazy[rt] = 0;
    }
}
void updata1(ll L,ll c,ll l,ll r,ll rt) //修改点 L需要修改的点 lr当前区间
{
    if(l==r)
    {
        tr[rt] += c;
        return ;
    }
    ll m = (l+r)>>1;
    if(L <= m) updata1(L,c,l,m,rt<<1);
    else updata1(L,c,m+1,r,rt<<1|1);
    pushup(rt);
}

void updata(ll L,ll R,ll c,ll l,ll r,ll rt)//修改区间 L R 为需要修改的区间
{                                          // l r 为当前线段树区间 c 为需要改动的大小
    if(L <= l&& r <= R)
    {
        tr[rt] += c*(r-l+1);
        lazy[rt] += c;
        return ;
    }
    ll m = (l+r)>>1;
    pushdown(rt,m-l+1,r-m); //改动点去掉
    if(L <= m) updata(L,R,c,l,m,rt<<1);
    if(R > m) updata(L,R,c,m+1,r,rt<<1|1);
    pushup(rt);
}

ll query(ll L,ll R,ll l,ll r,ll rt) //查询 L R需要查询区间 lr当前区间
{
    if(L<=l&&r <= R)
    {
        return tr[rt];
    }
    ll m = (l+r)>>1;
    pushdown(rt,m-l+1,r-m);//改动点去掉这句
    ll ans = 0;
    if(L <= m) ans+=query(L,R,l,m,rt<<1);
    if(R > m) ans += query(L,R,m+1,r,rt<<1|1);
    return ans;
}
int main()
{
    ll n,m,i,j,t,l,w,r;
    char c;
    scanf("%lld%lld",&n,&m);
    for(i=1;i<=n;i++)
    {
        scanf("%lld",&a[i]);
    }
    build(1,n,1);
    memset(lazy,0,sizeof(lazy));
    while(m--)
    {
        getchar();
        scanf("%c",&c);
        //printf("%c\n",c);
        if(c=='Q')
        {
            scanf("%lld%lld",&l,&r);
            ll ans = query(l,r,1,n,1);
            printf("%lld\n",ans);
        }
        else if(c=='C')
        {
            scanf("%lld%lld%lld",&l,&r,&w);
            updata(l,r,w,1,n,1);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值