POJ 3257 Cow Roller Coaster 二维背包

题目描述

The cows are building a roller coaster! They want your help to design as fun a roller coaster as possible, while keeping to the budget.

The roller coaster will be built on a long linear stretch of land of length L (1 ≤ L ≤ 1,000). The roller coaster comprises a collection of some of the N (1 ≤ N ≤ 10,000) different interchangable components. Each component i has a fixed length Wi (1 ≤ Wi ≤ L). Due to varying terrain, each component i can be only built starting at location Xi (0 ≤ Xi ≤ L - Wi). The cows want to string together various roller coaster components starting at 0 and ending at L so that the end of each component (except the last) is the start of the next component.

Each component i has a "fun rating" Fi (1 ≤ Fi ≤ 1,000,000) and a cost Ci (1 ≤ Ci ≤ 1000). The total fun of the roller coster is the sum of the fun from each component used; the total cost is likewise the sum of the costs of each component used. The cows' total budget is B (1 ≤ B ≤ 1000). Help the cows determine the most fun roller coaster that they can build with their budget.

 

输入输出格式

输入格式:
 

Line 1: Three space-separated integers: L, N and B.

Lines 2..N+1: Line i+1 contains four space-separated integers, respectively: Xi, Wi, Fi, and Ci.

输出格式:
 

Line 1: A single integer that is the maximum fun value that a roller-coaster can have while staying within the budget and meeting all the other constraints. If it is not possible to build a roller-coaster within budget, output -1.

输入输出样例

输入样例#1 复制

5 6 10
0 2 20 6
2 3 5 6
0 1 2 1
1 1 1 3
1 2 5 4
3 2 10 2

输出样例#1 复制

17

说明

Taking the 3rd, 5th and 6th components gives a connected roller-coaster with fun value 17 and cost 7. Taking the first two components would give a more fun roller-coaster (25) but would be over budget.

算法分析

题意:

奶牛们正打算造一条过山车轨道.她们希望你帮忙,找出最有趣,但又符合预算 的方案. 过山车的轨道由若干钢轨首尾相连,由x=0处一直延伸到X=L(1≤L≤1000)处.现有N(1≤N≤10000)根钢轨,每根钢轨的起点 Xi(0≤Xi≤L- Wi),长度wi(l≤Wi≤L),有趣指数Fi(1≤Fi≤1000000),成本Ci(l≤Ci≤1000)均己知.请确定一 种最优方案,使得选用的钢轨的有趣指数之和最大,同时成本之和不超过B(1≤B≤1000)

分析:

二维背包问题

DP[i][j]表示在i位置花费为j时最大有趣值。

初始化:DP[i][j]为-1

        DP[0][0]=0

状态转移方程:dp[a[i].e][j]=max(dp[a[i].e][j],dp[a[i].s][j-a[i].c]+a[i].f);

状态转移方程条件:if(dp[a[i].s][j-a[i].c]>=0)  //判断起点是否可以走得通

代码实现

#include<cstdio>  
#include<cstring>  
#include<cstdlib>  
#include<cctype>  
#include<cmath>  
#include<iostream>  
#include<sstream>  
#include<iterator>  
#include<algorithm>  
#include<string>  
#include<vector>  
#include<set>  
#include<map>  
#include<stack>  
#include<deque>  
#include<queue>  
#include<list>  
using namespace std;  
const double eps = 1e-8;  
typedef long long LL;  
typedef unsigned long long ULL;  
const int INT_INF = 0x3f3f3f3f;  
const int INT_M_INF = 0x7f7f7f7f;  
const LL LL_INF = 0x3f3f3f3f3f3f3f3f;  
const LL LL_M_INF = 0x7f7f7f7f7f7f7f7f;  
const int dr[] = {0, 0, -1, 1, -1, -1, 1, 1};  
const int dc[] = {-1, 1, 0, 0, -1, 1, -1, 1};  
const int MOD = 1e9 + 7;  
const double pi = acos(-1.0);  
const int MAXN = 1e5 + 10;  
const int MAXT = 10000 + 10;  
const int M=10010;
struct node
{
	int s,e,f,c;
};
bool cmp(const node &a,const node &b)
{
	  if(a.s==b.s)
	  	return a.e<b.e;
	  else 
	  	return a.s<b.s;
}  
node a[10010];
int dp[1010][1010];
int main()
{
	 int l,n,b;
	while(scanf("%d%d%d",&l,&n,&b)!=EOF)
	{
	  
	   	for(int i=1;i<=n;i++)
	   	{
	   		int t;
	   		scanf("%d%d%d%d",&a[i].s,&t,&a[i].f,&a[i].c);
	   		a[i].e=a[i].s+t;
	   	}
	   	sort(a+1,a+n+1,cmp);
	   	
	   	memset(dp,-1,sizeof(dp));
	   	dp[0][0]=0;
	   	
	   	for(int i=1;i<=n;i++)
		 for(int j=b;j>=a[i].c;j--)
		{
			if(dp[a[i].s][j-a[i].c]>=0)  //判断起点是否可以走得通
			dp[a[i].e][j]=max(dp[a[i].e][j],dp[a[i].s][j-a[i].c]+a[i].f);
		}
		int ans=-1;
		for(int i=1;i<=b;i++)
			ans=max(ans,dp[l][i]) ;
		printf("%d\n",ans);
	   
	}
    return 0;
}

 

                    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值