POJ 1008 Maya Calendar 日历转换

Maya Calendar

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 82755

 

Accepted: 25404

Description

During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor. 

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles. 

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows: 

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . . 

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was: 

Haab: 0. pop 0 

Tzolkin: 1 imix 0 
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar. 

Input

The date in Haab is given in the following format: 
NumberOfTheDay. Month Year 

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000. 

Output

The date in Tzolkin should be in the following format: 
Number NameOfTheDay Year 

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates. 

Sample Input

3

10. zac 0

0. pop 0

10. zac 1995

Sample Output

3

3 chuen 0

1 imix 0

9 cimi 2801

Source

Central Europe 1995

算法分析:

题意:

两个规则的年份制度,转换而已。

分析:

首先,我们知道无论怎么转换,都是意日为基本单位,所以我们先把Haab日历转换为一共有多少天(具体实现看代码),然后我简单说一下Tzolkin日历的计数方式,它的一年相当于260天,他也没有月份(字母)之说,或者它的属于一个月份的日子不是连续出现,而是一定周期出现的,所以其实把它月份看成另一种日子来看就行,20天一轮回,那个数字是13天一轮回。

注意输入数据和字符串准确性,wrong了好几次

代码实现:

#include<iostream>
#include<string>
#include<cstdio>
using namespace std;
string h[19]={"pop","no","zip","zotz","tzec","xul","yoxkin","mol","chen","yax","zac","ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};
string t[20] = { "imix", "ik", "akbal", "kan", "chicchan", "cimi", "manik", "lamat", "muluk", "ok", "chuen", "eb", "ben", "ix", "mem", "cib", "caban", "eznab", "canac", "ahau" };
int main()
{
    int T;
    cin>>T;
    cout<<T<<endl;    //坑人
    while(T--)
    {
      int d,y;
      string m;
      scanf("%d.",&d); //输入注意
      cin>>m;
      scanf("%d",&y);
      int a;
      for(int i=0;i<19;i++)
        if(m==h[i])
             {a=i;break;}

      int sum=a*20+d+y*365;  //不要考虑最后一个月五天的情况,因为这里的i是代表前几个月的,
                             //因为五天在最后一个月,过完了进往年进,对答案没有影响

      int year=sum/260;
      int month=sum%20;
      int day=sum%13+1;

      cout<<day<<" "<<t[month]<<" "<<year<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值