HDU5310(bestcoder一周年1001)

Souvenir

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 704    Accepted Submission(s): 430


Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, wants to buy a souvenir for each contestant. You can buy the souvenir one by one or set by set in the shop. The price for a souvenir is p yuan and the price for a set of souvenirs if q yuan. There's m souvenirs in one set.

There's n contestants in the contest today. Soda wants to know the minimum cost needed to buy a souvenir for each contestant.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105) , indicating the number of test cases. For each test case:

There's a line containing 4 integers n,m,p,q (1n,m,p,q104) .
 

Output
For each test case, output the minimum cost needed.
 

Sample Input
  
  
2 1 2 2 1 1 2 3 4
 

Sample Output
  
  
1 3
Hint
For the first case, Soda can use 1 yuan to buy a set of 2 souvenirs. For the second case, Soda can use 3 yuan to buy a souvenir.
 

Source
BestCoder 1st Anniversary ($)
注意边界情况
#include<stdio.h>
#include<math.h>
int main()
{
    int t,n,m,p,q,yu,sum;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            sum=0;
            scanf("%d%d%d%d",&n,&m,&p,&q);
            if(p*m<=q)
            {
                sum=p*n;
            }
            else
            {
                yu=n%m;
                if(yu*p<=q)
                {
                    sum=n/m*q+yu*p;
                }
                else
                    sum=(n/m+1)*q;
            }
            printf("%d\n",sum);
                
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值