08-图8 How Long Does It Take (25 分)

08-图8 How Long Does It Take (25 分)

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N−1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output “Impossible”.

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4结尾无空行

Sample Output 1:

18



结尾无空行

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible

Code1:

#include <bits/stdc++.h>
#define mem(a, b) memset(a, b, sizeof a)
#define INF 0x3f3f3f3f;
using namespace std;
const int maxm = 10010;
struct edge
{
    int u, v, w;
} es[maxm];
int n, m;
int dis[maxm], out[maxm];
void init()
{
    mem(dis, 0), mem(out, 0);
}
//使用 solve(求最长路径),注意:存在多个出口。
//跟bellman-ford相反 
//n轮如果还增加就有环
int solve()
{
    int f;
    for (int i = 1; i <= n; i++)
    {
        f = 0;
        for (int j = 0; j < m; j++)
            if (dis[es[j].u] + es[j].w > dis[es[j].v])
                f = 1, dis[es[j].v] = dis[es[j].u] + es[j].w;
        if (!f)
            return 1;
    }
    return 0;
}

int main()
{
    init();
    scanf("%d%d", &n, &m);
    for (int i = 0; i < m; i++)
    {
        scanf("%d%d%d", &es[i].u, &es[i].v, &es[i].w);
        out[es[i].u]++;
    }
    vector<int> vd; // 最后一个测试点:存在多个出路
    for (int i = 0; i < n; i++)
        if (!out[i])
            vd.push_back(i);
    if (solve())
    {
        int rs = -1;
        for (int i = 0; i < vd.size(); i++)
            rs = max(rs, dis[vd[i]]);
        printf("%d\n", rs);
    }
    else
        puts("Impossible");
    return 0;
}

Code2:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 105;
const int inf = 999999;
int G[maxn][maxn], dis[maxn];
vector<int> in(maxn); //入度
int n, m;
void solve()
{
    int cnt = 0, leastTime = 0;
    queue<int> q;
    for (int i = 0; i < n; i++)
    {
        if (!in[i])
            q.push(i); //将入度为0的入队
    }
    while (!q.empty())
    {
        int u = q.front();
        q.pop();
        cnt++;
        for (int v = 0; v < n; v++)
        {
            if (G[u][v] != inf)
            {
                if (--in[v] == 0)
                    q.push(v); //入度为0就入队
                if (dis[u] + G[u][v] > dis[v])
                    dis[v] = dis[u] + G[u][v]; //永远取最长的
                if (dis[v] > leastTime)
                    leastTime = dis[v]; //记录最长耗时
            }
        }
    }
    if (cnt == n)
        cout << leastTime << endl;
    else
        cout << "Impossible\n";
}
int main()
{
    fill(G[0], G[0] + maxn * maxn, inf);
    cin >> n >> m;
    for (int i = 0; i < m; i++)
    {
        int a, b, c;
        cin >> a >> b >> c;
        G[a][b] = c;
        in[b]++;
    }
    solve();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追寻远方的人

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值