poj 3134 Power Calculus

Power Calculus

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 3716Accepted: 2082

Description

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x2 = x × x, x3 = x2 × x, x4 = x3 × x, …, x31 = x30 × x.

The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:

x2 = x × x, x3 = x2 × x, x6 = x3 × x3, x7 = x6 × x, x14 = x7 × x7, x15 = x14 × x, x30 = x15 × x15, x31 = x30 × x.

This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:

x2 = x × x, x4 = x2 × x2, x8 = x4 × x4, x8 = x4 × x4, x10 = x8 × x2, x20 = x10 × x10, x30 = x20 × x10, x31 = x30 × x.

If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division)

:x2 = x × x, x4 = x2 × x2, x8 = x4 × x4, x16 = x8 × x8, x32 = x16 × x16, x31 = x32 ÷ x.

This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer n. n is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.

Sample Input

1
31
70
91
473
512
811
953
0

Sample Output

0
6
8
9
11
9
13
12

Source

Japan 2006

Submit

#include <iostream>
#include <cmath>
using namespace std;
int val[1010]; //保存一个搜索路径上的每一步的计算结果
int pos, n;
bool ida(int now, int depth)
{
    if (now > depth)
        return false; // IDDFS:大于当前设定的DFS深度,退出
    if (val[pos] << (depth - now) < n)
        return false;  //估价函数:用最快的倍增都不能达到n,退出
    if (val[pos] == n) //当前结果等于n,搜索结束
        return true;
    pos++;
    for (int i = 0; i < pos; i++)
    {
        val[pos] = val[pos - 1] + val[i]; //上一个数与前面所有的数相加
        if (ida(now + 1, depth))
            return true;
        //  val[pos] = abs(val[pos - 1] - val[i]);
        val[pos] = val[pos - 1] > val[i] ? val[pos - 1] - val[i] : val[i] - val[pos - 1]; //上一个数与前面所有的数相减
        if (ida(now + 1, depth))
            return true;
    }
    pos--;
    return false;
}
int main()
{
    int t;
    while (cin >> n && n)
    {
        int depth;
        for (depth = 0;; depth++) //每次只DFS到深度depth
        {
            val[pos = 0] = 1;  //初始值是1
            if (ida(0, depth)) //每次都是从0层开始DFS到第depth层
                break;
        }
        cout << depth << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追寻远方的人

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值