【POJ 3134】Power Calculus

【题目】

传送门

Description

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x 2 = x × x , x 3 = x 2 × x , x 4 = x 3 × x , … , x 31 = x 30 × x x^2 = x × x, x^3 = x^2 × x, x^4 = x^3 × x, …, x^{31} = x^{30} × x x2=x×x,x3=x2×x,x4=x3×x,,x31=x30×x.

The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:

x 2 = x × x , x 3 = x 2 × x , x 6 = x 3 × x 3 , x 7 = x 6 × x , x 14 = x 7 × x 7 , x 15 = x 14 × x , x 30 = x 15 × x 15 , x 31 = x 30 × x x^2 = x × x, x^3 = x^2 × x, x^6 = x^3 × x^3, x^7 = x^6 × x, x^{14} = x^7 × x^7, x^{15} = x^{14} × x, x^{30} = x^{15} × x^{15}, x^{31} = x^{30} × x x2=x×x,x3=x2×x,x6=x3×x3,x7=x6×x,x14=x7×x7,x15=x14×x,x30=x15×x15,x31=x30×x.

This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:

x 2 = x × x , x 4 = x 2 × x 2 , x 8 = x 4 × x 4 , x 8 = x 4 × x 4 , x 10 = x 8 × x 2 , x 20 = x 10 × x 10 , x 30 = x 20 × x 10 , x 31 = x 30 × x x^2 = x × x, x^4 = x^2 × x^2, x^8 = x^4 × x^4, x^8 = x^4 × x^4, x^{10} = x^8 × x^2, x^{20} = x^{10} × x^{10}, x^{30} = x^{20} × x^{10}, x^{31} = x^{30} × x x2=x×x,x4=x2×x2,x8=x4×x4,x8=x4×x4,x10=x8×x2,x20=x10×x10,x30=x20×x10,x31=x30×x.

If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):

x 2 = x × x , x 4 = x 2 × x 2 , x 8 = x 4 × x 4 , x 16 = x 8 × x 8 , x 32 = x 16 × x 16 , x 31 = x 32 ÷ x x^2 = x × x, x^4 = x^2 × x^2, x^8 = x^4 × x^4, x^{16} = x^8 × x^8, x^{32} = x^{16} × x^{16}, x^{31} = x^{32} ÷ x x2=x×x,x4=x2×x2,x8=x4×x4,x16=x8×x8,x32=x16×x16,x31=x32÷x.

This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integer n. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer n. n is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.

Sample Input

1
31
70
91
473
512
811
953
0

Sample Output

0
6
8
9
11
9
13
12


【分析】

大致题意:给出 n n n,询问至少要多少次乘除可以使 x x x 变成 x n x^n xn(不太懂的可以看题目描述,写的很清楚)

应该是一道迭代加深的入门题吧

就是不断地增加搜索的深度,如果在当前深度能够使 x x x 变成 x n x^n xn,那最后的答案就是当前深度

注意代码中有一个剪枝( x &lt; &lt; ( h − d e p ) &lt; n x&lt;&lt;(h-dep)&lt;n x<<(hdep)<n),它的意思是,如果每次按最大的来取(即每次都平方)都小于 n n n 的话,那肯定就不行,直接 r e t u r n return return f a l s e false false

【代码】

#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 1005
using namespace std;
int n,h,a[N];
bool dfs(int x,int dep)
{
	if(dep>h)  return false;
	if(x==n)  return true;
	if(x<<(h-dep)<n)  return false;
	a[dep]=x;
	for(int i=0;i<=dep;++i)
	{
		if(dfs(a[i]+x,dep+1))  return true;
		if(dfs(abs(a[i]-x),dep+1))  return true;
	}
	return false;
}
int main()
{
	while(scanf("%d",&n)&&n)
	{
		h=0;
		while(!dfs(1,0))  h++;
		printf("%d\n",h);
	}
	return 0;
}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值