HDU 4407 Sum 解题报告(容斥原理)

96 篇文章 0 订阅

Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1710    Accepted Submission(s): 477


Problem Description
XXX is puzzled with the question below: 

1, 2, 3, ..., n (1<=n<=400000) are placed in a line. There are m (1<=m<=1000) operations of two kinds.

Operation 1: among the x-th number to the y-th number (inclusive), get the sum of the numbers which are co-prime with p( 1 <=p <= 400000).
Operation 2: change the x-th number to c( 1 <=c <= 400000).

For each operation, XXX will spend a lot of time to treat it. So he wants to ask you to help him.
 

Input
There are several test cases.
The first line in the input is an integer indicating the number of test cases.
For each case, the first line begins with two integers --- the above mentioned n and m.
Each the following m lines contains an operation.
Operation 1 is in this format: "1 x y p". 
Operation 2 is in this format: "2 x c".
 

Output
For each operation 1, output a single integer in one line representing the result.
 

Sample Input
  
  
1 3 3 2 2 3 1 1 3 4 1 2 3 6
 

Sample Output
  
  
7 0
 

Source
 

    解题报告:至多1000次更改操作,直接暴力处理。求和时使用容斥原理即可,和前几篇博客一样,分解质因数,奇加偶剪。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long LL;

int change[1001];
int newnum[1001];
int changeNum;

int prime[100010];
int primeNum;

LL co_prime_sum(int n, int m)
{
    LL ans = (long long)m*(m+1)/2 - (long long)n*(n-1)/2;
    n--;

    for(int i=1;i<(1<<primeNum);i++)
    {
        int tmp = 1;
        bool flag = false;
        for(int j=0;j<primeNum;j++) if(i&(1<<j))
            tmp *= prime[j], flag = !flag;

        if(flag)
            ans-=((long long)m/tmp*(m/tmp+1)/2 - (long long)(n/tmp)*(n/tmp+1)/2)*tmp;
        else
            ans+=((long long)m/tmp*(m/tmp+1)/2 - (long long)(n/tmp)*(n/tmp+1)/2)*tmp;
    }

    return ans;
}

int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}

void work()
{
    changeNum = 0;

    int n,m;
    scanf("%d%d",&n,&m);

    while(m--)
    {
        int op;
        scanf("%d", &op);
        if(op==1)
        {
            int l,r,p;
            scanf("%d%d%d",&l,&r,&p);

            LL res = 0;
            for(int i=0;i<changeNum;i++) if(change[i]>=l && change[i]<=r)
            {
                if(gcd(change[i], p)==1) res-=change[i];
                if(gcd(newnum[i], p)==1) res+=newnum[i];
            }

            primeNum = 0;
            for(int i=2;i*i<=p;i++) if(p%i==0)
            {
                prime[primeNum++]=i;
                while(p%i==0) p/=i;
            }
            if(p>1) prime[primeNum++]=p;

            res += co_prime_sum(l,r);
            printf("%I64d\n",res);
        }
        else
        {
            int x,v;
            scanf("%d%d",&x,&v);

            bool has = false;
            for(int i=0;i<changeNum;i++) if(change[i]==x)
            {
                has = true;
                newnum[i] = v;
            }
            if(!has)
            {
                change[changeNum] = x;
                newnum[changeNum] = v;
                changeNum++;
            }
        }
    }
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
        work();
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值