POJ 3735 Training little cats 解题报告(矩阵构造+快速幂优化)

96 篇文章 0 订阅
6 篇文章 0 订阅
Training little cats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9396 Accepted: 2249

Description

Facer's pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer's great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers nm and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output

2 0 1

Source

   

    解题报告: WA/TLE很久的一道题。

    用long long TLE, unsigned WA,纠结至死……无奈看Discuss,发现了惊人的答案:矩阵乘法优化。其实以前就知道的。如果某一行很多个0,可以先判断是否为0,是就不用乘了。这样乘法的复杂度从100W直接降到1W左右(每行最多两个数不为0),乘上m的快速幂也不会超时了。

    代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int SIZE=101;
typedef long long LL;
int n;

struct Matrix
{
    LL a[SIZE][SIZE];

    Matrix(int t=0)
    {
        memset(a, 0, sizeof(a));
        for(int i=0;i<SIZE;i++) a[i][i]=t;
    }

    Matrix operator*(const Matrix& b) const
    {
        Matrix c;
        for(int k=0;k<=n;k++)
            for(int i=0;i<=n;i++) if(a[i][k])
                for(int j=0;j<=n;j++) if(b.a[k][j])
                    c.a[i][j]+=a[i][k]*b.a[k][j];
        return c;
    }
};

Matrix powM(Matrix a, int b)
{
    Matrix res(1);
    while(b)
    {
        if(b&1)
            res=res*a;
        a=a*a;
        b>>=1;
    }
    return res;
}

int main()
{
    int m, k;
    while(~scanf("%d%d%d", &n, &m, &k) && (n||m||k))
    {
        Matrix op(1);
        while(k--)
        {
            char ch[2];
            scanf("%s", ch);

            if(ch[0]=='g')
            {
                int t;
                scanf("%d", &t);
                op.a[0][t]++;
            }
            else if(ch[0]=='e')
            {
                int t;
                scanf("%d", &t);
                for(int i=0;i<=n;i++)
                    op.a[i][t]=0;
            }
            else
            {
                int a, b;
                scanf("%d%d", &a, &b);
                for(int i=0;i<=n;i++)
                    swap(op.a[i][a], op.a[i][b]);
            }
        }

        op=powM(op, m);

        for(int i=1;i<=n;i++)
            printf("%lld ", op.a[0][i]);
        puts("");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值