HDU 3664 Permutation Counting 解题报告(递推)

11 篇文章 0 订阅

Permutation Counting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1446    Accepted Submission(s): 736


Problem Description
Given a permutation a1, a2, … aN of {1, 2, …, N}, we define its E-value as the amount of elements where ai > i. For example, the E-value of permutation {1, 3, 2, 4} is 1, while the E-value of {4, 3, 2, 1} is 2. You are requested to find how many permutations of {1, 2, …, N} whose E-value is exactly k.
 

Input
There are several test cases, and one line for each case, which contains two integers, N and k. (1 <= N <= 1000, 0 <= k <= N).
 

Output
Output one line for each case. For the answer may be quite huge, you need to output the answer module 1,000,000,007.
 

Sample Input
  
  
3 0 3 1
 

Sample Output
  
  
1 4
Hint
There is only one permutation with E-value 0: {1,2,3}, and there are four permutations with E-value 1: {1,3,2}, {2,1,3}, {3,1,2}, {3,2,1}
 

Source
 

    解题报告:下午队伍一起做了一场哈工大的比赛,说起来很搞笑,三个人都没思路(真的……)。简单暴力,列出简单数据的结果,然后找规律……

    得到一个类似于杨辉三角的图形,然后三个人一起YY公式,然后就A了……

    正式正确的姿势不是这样的啊(╯‵□′)╯︵┴─┴

    赛后看了解题报告。dp[i][j]表示使用1~i这些数,使得k=j的情况数。那么递推公式为:

    dp[i][j] = dp[i-1][j] * (j + 1) + dp[i-1][j-1] * ((i-1) - (j-1))

    简单来说就是新增一个数i时,如果把这个放在第i位,或者与前面出现的ax > x中的某个数交换,k保持不变;如果与ax <= x交换,则k+1。

    边界条件为dp[0][0] = 1,递推即可,没啥好说的……

#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <vector>
#include <functional>
using namespace std;

typedef long long ll;
typedef unsigned long long ull;

#define ff(i, n) for(int i=0,END=(n);i<END;i++)
#define fff(i, n, m) for(int i=(n),END=(m);i<=END;i++)
#define dff(i, n, m) for(int i=(n),END=(m);i>=END;i--)
#define mid ((l+r)/2)
#define bit(n) (1ll<<(n))
#define clr(a, b) memset(a, b, sizeof(a))

void work();

int main() {
    work();
    return 0;
}

/**************************Beautiful GEGE**********************************/

const int mod = 1e9 + 7;
const int maxn = 1111;
ll dp[maxn][maxn];

void work() {
    dp[0][1] = 1;
    fff (i, 1, 1000) fff (j, 1, i) {
        dp[i][j] = (dp[i - 1][j] * j + dp[i - 1][j - 1] * (i - j + 1)) % mod;
    }

    int n, k;
    while(scanf("%d%d", &n, &k) == 2) {
        printf("%lld\n", dp[n][k + 1]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值