HDU 5477 A Sweet Journey 【更新最小值】

Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

Input

In the first line there is an integer t (1≤t≤501≤t≤50), indicating the number of test cases. 
For each test case: 
The first line contains four integers, n, A, B, L. 
Next n lines, each line contains two integers: Li,RiLi,Ri, which represents the interval [Li,Ri][Li,Ri] is swamp. 
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L. 
Make sure intervals are not overlapped which means Ri<Li+1Ri<Li+1 for each i (1≤i<n1≤i<n).
Others are all flats except the swamps. 

Output

For each text case: 
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning. 

Sample Input

1
2 2 2 5
1 2
3 4

Sample Output

Case #1: 0

题意:有一个人带着他女朋友去旅行,有平地,有沼泽,沼泽减速(减能),平地加速(加能),问开始的时候需要的最小速度(能量)是多少???

代码如下:

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
    int t,n,A,B,L,p=0,x,y;
    while(scanf("%d",&t)!=EOF)
    {
    
    while(t--)
    {
        int ans=0,s=0;
        int q=0;
        scanf("%d%d%d%d",&n,&A,&B,&L);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x ,&y );
            s+=(x-q)*B;
            s-=(y-x)*A;
            ans=min(ans,s);
            q=y;
    
        }
        if(ans>0)
        {
            printf("Case #%d: %d\n",++p,ans);
        }
        else
        {
            printf("Case #%d: %d\n",++p,abs(ans));
        }
    }
    
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值